Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235698 - Switch user button doesn't work when multiple server definitions exist
Summary: Switch user button doesn't work when multiple server definitions exist
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-screensaver
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-09 18:03 UTC by Stewart Adam
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 11:27:35 UTC


Attachments (Terms of Use)

Description Stewart Adam 2007-04-09 18:03:13 UTC
Description of problem:
When multiple servers are defined, running gdmflexiserver asks 'Chooser X server
to start' so as a result when the screensaver is locked, clicking "Switch User"
has no effect since the dialog appears behind the locked screen.

Version-Release number of selected component (if applicable):
gdm-2.18.0-7.fc7
gnome-screensaver-2.18.0-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. Create two or more server defs in custom.conf
2. Try to switch users while screen is locked
  
Actual results:
Dialog appears behind locked screensaver (nothing happens from the user's point
of view)

Expected results:
The dialog appears on top of the locked screen, or it just goes ahead and starts
the default server

Additional info:

Comment 1 Matthias Clasen 2007-04-09 21:56:57 UTC
Might be best to just add an option to gdmflexiserver to force it to use the
default server.

Comment 2 Matthias Clasen 2007-04-10 11:09:36 UTC
Turns out this is not a problem for the fus-applet, since it uses gdm socket
commands to spawn a new flexiserver. But gnome-screensaver simply runs
gdmflexiserver --start-new. As it turns out, gdmflexiserver already accepts an
X server id as last argument, so one way to improve things would be to make
gnome-screensaver run "gdmflexiserver --start-new Standard". That will work 
with multiple server definitions in the gdm configuration as long as 

a) the "Standard" server is not removed
b) the "Standard" server is flexible

Comment 3 Matthias Clasen 2007-04-10 11:27:35 UTC
This fix is in 2.18.0-7.fc7


Note You need to log in before you can comment on or make changes to this bug.