Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235697 - GFS2 requires a minimum lock hold time for glocks
Summary: GFS2 requires a minimum lock hold time for glocks
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Fedora
Classification: Fedora
Component: GFS-kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Whitehouse
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 236404
TreeView+ depends on / blocked
 
Reported: 2007-04-09 17:56 UTC by Steve Whitehouse
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-25 13:42:41 UTC


Attachments (Terms of Use)

Description Steve Whitehouse 2007-04-09 17:56:40 UTC
To solve the performance problems seen with the alternate test and similar
contention cases, we need to implement some kind of minimum lock hold time to
ensure that the cluster makes progress even in heavy lock traffic.

Probably we need a user configurable, but with a sensible default, setting which
puts a maximum cap on the minimum lock hold time, and then try to set the lock
hold time automatically using information gathered from the system, such as how
long the wait has been when acquiring the lock, how much work needs to be done, etc.

Comment 1 Steve Whitehouse 2007-08-25 13:42:41 UTC

*** This bug has been marked as a duplicate of 248480 ***


Note You need to log in before you can comment on or make changes to this bug.