Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235674 - Incorrect elfutils_version value in systemtap.spec
Summary: Incorrect elfutils_version value in systemtap.spec
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap
Version: 5.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Frank Ch. Eigler
QA Contact: Radek Bíba
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 15:05 UTC by Vesselin Kolev
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 15:27:51 UTC


Attachments (Terms of Use)

Description Vesselin Kolev 2007-04-09 15:05:12 UTC
Description of problem:

Incorrect elfutils_version value in systemtap.spec - 0.124. Correct version is
0.125!

Version-Release number of selected component (if applicable):

0.5.12-1.el5


How reproducible:

Always

Steps to Reproduce:
1. rpm -i
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/systemtap-0.5.12-1.el5.src.rpm
2. rpm -i
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/elfutils-0.125-3.el5.src.rpm
3. rpmbuild -ba --define="dist .el5" systemtap.spec
  
Actual results:

error: File /usr/src/redhat/SOURCES/elfutils-0.124.tar.gz: No such file or directory

Expected results:


Additional info:

Comment 1 Frank Ch. Eigler 2007-04-09 15:27:51 UTC
While you are correct that the systemtap spec file refers to an older elfutils
source, this is not in fact used for RHEL5 builds.  On RHEL5, the spec file
arranges to unset the "bundled_elfutils" flag, which makes systemtap build
against the system elfutils library.

Comment 2 Vesselin Kolev 2007-04-09 16:08:02 UTC
I thing, that this may cause problem when someone tries to compile embeded
system based on RHEL5 sources. You are right, that (at this time and version of
spec) the correct build must be produced lake that:

$ rpmbuild --sign -ba --define="dist .el5" --define="rhel 5" systemtap.spec

but I think that spec file must be corrected in the future.

Regards


Note You need to log in before you can comment on or make changes to this bug.