Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235662 - F7-T3:Changing laguages causes aplications to use old language desktop folder instead of the new translated one.
Summary: F7-T3:Changing laguages causes aplications to use old language desktop folder...
Keywords:
Status: CLOSED DUPLICATE of bug 235661
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-desktop
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 11:49 UTC by FranciscoMendonça
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 14:59:02 UTC


Attachments (Terms of Use)

Description FranciscoMendonça 2007-04-09 11:49:04 UTC
Description of problem:
When changing system languages, several folders on the /home/user are created
instead of renamed to match the new language. Among these folders is the Desktop.
For starters the folders should be renamed to keep files on their respective
equivalents, but the biggest problem is with the Desktop folder. The Desktop
folder displayed is the new translated one, but for gnome applications (nautilus
not included) the name displayed is the translated but the folder is the old
Desktop folder.

Version-Release number of selected component (if applicable):
FC7 Test 3 with Gnome.

How reproducible:

Just change your language in System/Administration/Language, in this case we
will be using Portuguese. Logout and login again and you'll be prompted to
create the new folders. Chooose yess
Steps to Reproduce:
1. Create a file on the "Desktop" folder named "old". And a new on your recently
created "Ambiente de Trabalho" folder (Portuguese equivalent for desktop) create
a file named "new".
2. Everything works ok if you browse with nautilus, although the files that were
on the desktop prior to the new language SHOULD be copied to the new "Ambiente
de Trabalho" folder.
3. Open any application, We will be using gimp. Choose open file and on locals
(the side bar) Choose "Ambiente de trabalho". As you can see there by the "old"
file displayed we are looking at the old Desktop folder (the one prior to the
translation) instead of the new one.
  
Actual results:
1- Files on old language folders aren't moved to the new ones and the old
folders aren't deleted.
2- Most applications still use the old folders instead of the new translated ones.

Expected results:
1- Old folders simply renamed to their new language equivalent.
2-Applications should use the new language ones instead of pointing to the old ones.

Additional info:

Comment 1 Ray Strode [halfline] 2007-04-09 14:59:02 UTC

*** This bug has been marked as a duplicate of 235661 ***


Note You need to log in before you can comment on or make changes to this bug.