Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235638 - Pirut switch back to Englsih after installing a package
Summary: Pirut switch back to Englsih after installing a package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 247603 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-08 19:34 UTC by Thomas Canniot
Modified: 2009-09-21 21:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-10 19:56:30 UTC


Attachments (Terms of Use)

Description Thomas Canniot 2007-04-08 19:34:55 UTC
Description of problem: Once you ave installed a package, Pirut text goes bak to
English instead of remaining in French.


Version-Release number of selected component (if applicable):
pirut-1.3.4-2.fc7 and FC6 most recent version.


How reproducible: Always


Steps to Reproduce:
1. Open Pirut
2. Install a package
3. 
  
Actual results:
Pirut interface is back to English

Expected results:
Should stay in the system language (French here)

Additional info:

Comment 1 Jeremy Katz 2007-04-09 15:20:39 UTC
Reproduced.  That is very very odd...

Comment 2 Thomas Canniot 2007-04-09 19:47:28 UTC
I can add that it doesn't happen when you remove a package.

Comment 3 Thomas Canniot 2007-05-18 17:57:45 UTC
It has been fixed hasn't it ?

Comment 4 Jeremy Katz 2007-05-18 18:07:46 UTC
I was still able to reproduce it the last time I tried.  But I have no better
idea as to why or how it's happening :-/

It may be that something at a lower level (glade or gtk) was broken and have
been fixed if you're nto seeing it anymore

Comment 5 Thomas Canniot 2007-05-18 19:31:29 UTC
I can't reproduce it today. It's fixed on my desktop.

Comment 6 Thomas Canniot 2007-05-31 19:17:12 UTC
Well, i've spoken to fast, the bug is still present on FC7.

Comment 7 Thomas Canniot 2007-07-16 10:22:06 UTC
I installed FC7 yesterday, all pirut interface does not switch back to English
now, but only the "optional packages" button on the main tab. Most of the second
and third tab is in Englsih, except the "Apply" button.

Comment 8 Jeremy Katz 2007-07-16 18:32:11 UTC
*** Bug 247603 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2007-08-10 19:56:30 UTC
I can't reproduce this anymore in rawhide after switching away from using
rhpl.translate.  I'm guessing that rhpl.translate was getting confused by
something in %post script or the like


Note You need to log in before you can comment on or make changes to this bug.