Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235635 - audio setup messed up on macbook pro (intel)
Summary: audio setup messed up on macbook pro (intel)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 17:32 UTC by Jussi Eloranta
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-16 14:16:23 UTC


Attachments (Terms of Use)
sound config log when audio works (deleted)
2007-04-10 15:55 UTC, Jussi Eloranta
no flags Details
config when sound does not work (deleted)
2007-04-10 15:56 UTC, Jussi Eloranta
no flags Details

Description Jussi Eloranta 2007-04-08 17:32:29 UTC
Description of problem:

After intial install on a macbook pro (intel), I got no audio. After playing with kmix, I was finally
able to get it to work. It looks like the channels are somehow setup incorrectly. Let me know, what
additional info I can provide on this. BTW after installing updates, this did not work either
(I recall that there was alsa update). 

Version-Release number of selected component (if applicable):


How reproducible:

Install FC6 on macbook pro and try to use the audio device.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Martin Stransky 2007-04-10 09:25:46 UTC
Please run system-config-soundcard, generate a log (/root/scsconfig.log) and
attach it here (when sound works and when it doesn't)

Comment 2 Jussi Eloranta 2007-04-10 15:55:53 UTC
Created attachment 152150 [details]
sound config log when audio works

Comment 3 Jussi Eloranta 2007-04-10 15:56:25 UTC
Created attachment 152151 [details]
config when sound does not work

Comment 4 Jussi Eloranta 2007-04-10 15:59:59 UTC
BTW here is what I did with kmix to get audio:

THe output panel:

The "the plug; side" needs to be checked and the volume
setting here seems to affect the volume. This was not checked
by default. Also PCM seems to control volume.

The switches panel:

"Line in as output" must be checked (not checked by default). Otherwise
no sound.


Comment 5 Martin Stransky 2007-05-16 14:06:12 UTC
Okay, I'll add it to alsa-utils. Thanks!

Comment 6 Martin Stransky 2007-05-16 14:16:23 UTC
added to CVS.

Comment 7 Fedora Update System 2007-05-21 22:25:09 UTC
alsa-utils-1.0.14-0.2.rc1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.