Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235632 - yum doesnt upgrade noarch.rpm to arch-specific rpm
Summary: yum doesnt upgrade noarch.rpm to arch-specific rpm
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 17:09 UTC by Michael E Brown
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 12:40:18 UTC


Attachments (Terms of Use)

Description Michael E Brown 2007-04-08 17:09:57 UTC
Description of problem:
  Yum will not upgrade from an installed .noarch.rpm to a higher versioned
.i386.rpm (or any other arch-specific pkg)

Version-Release number of selected component (if applicable):
yum-3.0.5-1.fc6


How reproducible:
  yum install firmware-addon-dell.noarch
  yum upgrade

  In the current fedora extras repo, there is 1.2.6-1.noarch available for
firmware-addon-dell (old, busted). There is also 1.2.11-1.{i386,x86_64} (new
hotness.) If you install the noarch ver, yum will not upgrade to the
arch-specific version.


Steps to Reproduce:
1.  yum install firmware-addon-dell.noarch
2.  yum  upgrade
3.  notice lack of updates listed for firmware-addon-dell
  
Actual results:
 yum upgrades lower-version noarch.rpm to a higher versioned arch-specific.rpm.

Expected results:
 yum leaves the old, busted version.

Additional info:
 I will be submitting a request to remove the noarch.rpm from the repo soon, or
if this cannot be fixed, might possibly convert my pkg back to noarch.

Comment 1 Michael Schwendt 2007-04-08 18:01:26 UTC
Cannot confirm.

$ rpm -q  firmware-addon-dell   
firmware-addon-dell-1.2.6-1.fc6

$ sudo yum update
[...]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for firmware-addon-dell to pack into transaction set.
firmware-addon-dell-1.2.1 100% |=========================| 6.1 kB    00:00     
---> Package firmware-addon-dell.i386 0:1.2.10-1.fc6 set to be updated
[...]
=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 firmware-addon-dell     i386       1.2.10-1.fc6     extras             25 k

Comment 2 Michael E Brown 2007-04-08 18:34:10 UTC
Can you also check noarch->x86_64, as my system is x86_64? I can confirm that
noarch->i386 appears to work, but noarch->x86_64 doesnt.

[michael_e_brown@localhost ~]$ rpm -q --qf
"%{name}-%{version}-%{release}-%{arch}\n" firmware-addon-dell
firmware-addon-dell-1.2.6-1.fc6-noarch

[michael_e_brown@localhost ~]$ sudo yum -y upgrade
[...]
Reading repository metadata in from local files
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
No Packages marked for Update/Obsoletion



Comment 3 Seth Vidal 2007-04-08 19:21:45 UTC
please send the following on the system and for the pkg that isn't upgrading for
you:

yum list pkgname

uname -a
cat /etc/rpm/platform



Comment 4 Michael E Brown 2007-04-08 19:48:28 UTC
[michael_e_brown@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:00:19 EDT
2007 x86_64 x86_64 x86_64 GNU/Linux

[michael_e_brown@localhost ~]$ sudo yum --noplugins list firmware-addon-dell
Setting up repositories
livna                     100% |=========================| 1.1 kB    00:00     
freshrpms                 100% |=========================|  951 B    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 110 kB    00:01     
livna     : ################################################## 322/322
primary.xml.gz            100% |=========================|  65 kB    00:01     
freshrpms : ################################################## 177/177
Installed Packages
firmware-addon-dell.noarch               1.2.6-1.fc6            installed       
Available Packages
firmware-addon-dell.x86_64               1.2.10-1.fc6           extras          

[michael_e_brown@localhost ~]$ cat /etc/rpm/platform 
ia32e-redhat-linux


Comment 5 Seth Vidal 2007-04-08 20:47:34 UTC
fix applied to cvs. I'll make a 3.0.6, shortly

http://linux.duke.edu/~skvidal/misc/updates-x86_64-noarch.patch



Comment 6 Michael E Brown 2007-04-08 23:26:20 UTC
Does not change yum behaviour for me.


Comment 7 Seth Vidal 2007-04-09 12:40:18 UTC
checked in one additional patch which solves it for ia32e, too.
https://lists.dulug.duke.edu/pipermail/yum-cvs-commits/2007-April/001620.html


Note You need to log in before you can comment on or make changes to this bug.