Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235629 - anaconda stops with "CRITICAL: parted exception: Error:../dev/hda4 -- Device or resource busy"
Summary: anaconda stops with "CRITICAL: parted exception: Error:../dev/hda4 -- Device ...
Keywords:
Status: CLOSED DUPLICATE of bug 238100
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 16:08 UTC by Tuan Nguyen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-04 19:21:34 UTC


Attachments (Terms of Use)
Dump from install, the install stops just after "checking the depedencies" (deleted)
2007-04-08 16:08 UTC, Tuan Nguyen
no flags Details

Description Tuan Nguyen 2007-04-08 16:08:19 UTC
Description of problem:

I have 4 primary partitions, 2 for Windows, 3rd for Fedora2 (hda3 ; type
identifier 0x83) and 4th for Solaris10 (hda4 ; 0xBF - see below)

When I try (had try 3 times) to install Fedora6 on hda3, the install stops with
"parted exception on hda4" after  I was finished with choosing the different
packages. The error can be found on the attached file.

Is this because the new type identifier from Sun?

NB: the DVD checksum is OK, the linux checkmedia is OK too.
NB2: the type identifier of Solaris is changed by Sun from 0x82 (same as linux
swap) to 0xBF for Solaris10 (http://www.sun.com/blueprints/0905/819-2889.pdf)

Version-Release number of selected component (if applicable):
DVD fedora 6

How reproducible:

Steps to Reproduce:
1. you must have a Solaris10 on your disk
2. boot from DVD, "linux" or "linux text"
 
dump from install:
13:09:53 INFO    : anaconda.methodstr = cdrom://hdc:/mnt/source 0
13:09:53 INFO    : moving (1) to step enablefilesystems
13:09:56 CRITICAL: parted exception: Error: Error informing the kernel about
modifications to partition /dev/hda4 -- Device or resource busy.  This means
Linux won't know about any changes you made to /dev/hda4 until you reboot -- so
you shouldn't mount it or use it in any way before rebooting.
 
Actual results:


Expected results:


Additional info:

Comment 1 Tuan Nguyen 2007-04-08 16:08:19 UTC
Created attachment 151931 [details]
Dump from install, the install stops just after "checking the depedencies"

Comment 2 Tuan Nguyen 2007-04-08 16:14:30 UTC
I forgot to write that the PC rebooted after I press the "done" button, I had
tried 3 times I got the same error.
Now I get back to fedora2 (I had "kino" working there), thanks to the
"trueimage" I made just before install fedora6.
Thanks
Tuan


Comment 3 David Cantrell 2007-05-04 19:21:34 UTC

*** This bug has been marked as a duplicate of 238100 ***


Note You need to log in before you can comment on or make changes to this bug.