Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235624 - Cannot get MIDI to play
Summary: Cannot get MIDI to play
Alias: None
Product: Fedora
Classification: Fedora
Component: jack-audio-connection-kit
Version: 6
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Andy Shevchenko
QA Contact: Fedora Extras Quality Assurance
Whiteboard: bzcl34nup
Depends On: 221785
TreeView+ depends on / blocked
Reported: 2007-04-08 14:09 UTC by Wayne Hammond
Modified: 2008-05-06 19:29 UTC (History)
2 users (show)

Fixed In Version: 0.103.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-05-06 19:29:11 UTC

Attachments (Terms of Use)

Description Wayne Hammond 2007-04-08 14:09:34 UTC
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Rosegarden
2.Attempt to open and play MIDI files
3.No sound output, qjackctl cannot start as user, only as root. Opening a
terminal and typing qjackctl opens jack and allows jack to start. MIDI still not
available for user.
Actual results:

Expected results:

Additional info:
Browsing web yeilded permissions issue.  Have not found solution as yet. Jack
appears to be in wrong location as when opening qjackctl as su an error message
appears: Warning: no locale found: /usr/share/locale/qjackctl_en_US.UTF-8.qm
but jack opens and can be started from terminal session as su.

Comment 1 Andy Shevchenko 2007-05-23 13:13:31 UTC
I'll push today the new version of the jack-audio-connection-kit to the devel 
repo. After it is built try to rebuild it on your fc6 box and after update 
just add yourself to the jackuser group.
The jackuser group is discussed at bug #221785. Please, refer to that bug 

Comment 2 Wayne Hammond 2007-05-25 02:50:25 UTC
I have tried to update, but the repository doesn't respond.  I added myself to
the jack group.  Attempting to open Jack gives this message:
21:47:18.372 Patchbay deactivated.
21:47:19.025 Statistics reset.
21:47:20.028 Startup script...
21:47:20.028 artsshell -q terminate(default)
21:47:20.067 MIDI connection graph change.
sh: -c: line 0: syntax error near unexpected token `('
sh: -c: line 0: `artsshell -q terminate(default)'
21:47:20.271 Startup script terminated with exit status=512.
21:47:20.289 JACK is starting...
21:47:20.289 jackd-realtime -v -R -dalsa -dhw:0 -r48000 -p1024 -n2
21:47:20.297 Could not start JACK. Sorry.
21:47:22.908 JACK was stopped successfully.
21:47:23.115 MIDI connection change.

Comment 3 Andy Shevchenko 2007-05-29 15:00:33 UTC
How is the '(default)' pice found in the command line? Try to check your 

Really, the last jack is allowed in the new rawhide repo (F-8 aka devel). But 
that repo isn't published while now (if I understand correctly). I'll put new 
jack in the F-7 repo in the near future (may be one or two weeks).

Comment 4 Andy Shevchenko 2007-06-11 13:12:35 UTC
Fixed for FC6, F-7, Rawhide. Please, check it and reopen this report if needs.

Comment 5 Wayne Hammond 2007-06-12 02:12:47 UTC
I believe I have the latest version of Jack as I have re-installed my operating
system as Fedora 7.  Attempts to open jack gives the following:

21:08:53.415 Patchbay deactivated.
21:08:53.447 Statistics reset.
21:08:53.830 MIDI connection graph change.
21:08:53.831 MIDI connection change.
21:08:55.959 Startup script...
21:08:55.960 artsshell -q terminate
sound server terminated
21:08:56.794 Startup script terminated successfully.
21:08:56.840 JACK is starting...
21:08:56.841 jackd -R -dalsa -dhw:0 -r48000 -p1024 -n2
21:08:56.851 JACK was started with PID=8349 (0x209d).
jackd 0.102.20
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1208584512,
from thread -1208584512] (1: Operation not permitted)
cannot create engine
21:08:57.025 JACK was stopped successfully.
21:08:58.866 Could not connect to JACK server as client. Please check the
messages window for more info.

Comment 6 Wayne Hammond 2007-06-22 14:29:59 UTC
Still cannot get jack to connect, but, perhaps this bug is related to this one
now:  245285    	  	  

Comment 7 Andy Shevchenko 2007-06-27 15:20:09 UTC
Please, show outputs of the following commands:
 rpm -q jack-audio-connection-kit
 grep -n jackuser /etc/security/limits.conf /etc/group

Comment 8 Wayne Hammond 2007-06-27 15:59:48 UTC
Output from  rpm -q jack-audio-connection-kit:

Output from grep -n jackuser /etc/security/limits.conf /etc/group:

Comment 9 Andy Shevchenko 2007-07-04 08:40:07 UTC
Please, update the package to the 0.103.0-1.

Comment 10 Andy Shevchenko 2007-11-11 21:03:52 UTC
Comment the current j-a-c-k behaviour for you, please.

Comment 11 David W. Legg 2007-12-29 11:55:19 UTC
All this stuff seems to work ok, even with Rosegarden on FC7.
See my guide here:

Comment 12 Wayne Hammond 2007-12-29 18:42:18 UTC
Since my last attempt, I have installed Fedora 8 with the hopes the interfaces
have improved.

Reinstalling jack, qsynth, and rosegarden using your tutorial did not solve my
problem. Jack would not start at all.  One of the messages in the Jack messgae
box was:
cannot use real-time scheduling (FIFO at priority 10) [for thread -1208645952,
from thread -1208645952] (1: Operation not permitted)

Un-checking the realtime parameter allowed starting.

Qsynth and Rosegarden then recognized jack as running, but I have no audio
output. Changing any other jack settings stops jack from loading.

Am I getting any closer to a resolution, or should I forget playing midi through
rosegarden? My wife would really like to use the program for music editing, but
is currently using a windows application because of the difficulty getting
interfaces to work in linux.

Comment 13 Bug Zapper 2008-04-04 06:49:01 UTC
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out

Comment 14 Bug Zapper 2008-05-06 19:29:09 UTC
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.