Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235623 - GtkFileChooser lacks visual feedback in text field when selecting file
Summary: GtkFileChooser lacks visual feedback in text field when selecting file
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeui
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 13:46 UTC by Frode Tennebø
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-18 18:41:54 UTC


Attachments (Terms of Use)

Description Frode Tennebø 2007-04-08 13:46:15 UTC
Description of problem:

Take any application which uses the GtkFileChooser widget, e.g. Gimp, and (what 
it takes to) open up the "Save as..." dialogue.  Provided the current folder is 
not empty and the filter is not excluding them, it should be possible to select 
a file from the file-list.

In FC5 this resulted in the selected name being presented in the top "Name:" 
text widget (i.e. where the filename is entered) for easy change of similar 
names or over-writing existing files.  However, now in FC6 this does not happen.

Version-Release number of selected component (if applicable):

[root@luke tmp]# rpm -q gimp libgnomeui
gimp-2.2.13-1.fc6
libgnomeui-2.16.0-4.fc6

How reproducible:

Always.

Steps to Reproduce:

See above.
  
Actual results:

The text filed stays blank (or "Untitled" for Gimp).

Expected results:

The selected name appears in the top "Name:" text field.

Additional info:

As this did not happen in FC5, I can only asume that this happened in the 
transition to FC6 and since both use the same version of the Gimp, version for 
FC5:

[root@leia rpm]# rpm -q gimp libgnomeui
gimp-2.2.13-1.fc5
libgnomeui-2.14.1-1.fc5.1

I can only asume that this is related to the libgnomeui package - I may be 
wrong though.  However, this behaviour is also identical in gedit.

Comment 1 Ray Strode [halfline] 2008-03-18 18:41:54 UTC
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)


Note You need to log in before you can comment on or make changes to this bug.