Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235621 - Dellsysidplugin crashes yum
Summary: Dellsysidplugin crashes yum
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firmware-addon-dell
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael E Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 12:29 UTC by Sean Stangl
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 1.2.10-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-08 22:39:49 UTC


Attachments (Terms of Use)

Description Sean Stangl 2007-04-08 12:29:21 UTC
Description of problem:
The Dellsysidplugin plugin crashes yum with the error below.

Version-Release number of selected component (if applicable):
firmware-addon-dell-1.2.6-1.fc6

How reproducible:
Always. Regardless of the arguments to yum, loading the plugin crashes it.
 

Python crashes with the following:

$ yum update
Loading "installonlyn" plugin
Loading "dellsysidplugin" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 82, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 206, in getOptionsConfig
    errorlevel=opts.errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 141, in
doConfigSetup
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/dellsysidplugin.py", line 26, in init_hook
    sysid = getSystemId()
  File "/usr/lib/python2.4/site-packages/biosHdr.py", line 34, in getSystemId
    output = cmdFactory_getSystemId()
  File "/usr/lib/python2.4/site-packages/biosHdr.py", line 27, in
cmdFactory_getSystemId
    raise PermissionDenied("Failed to get System ID: %s" % output)
biosHdr.PermissionDenied: Failed to get System ID: Libsmbios:    0.13.5
Error getting the System ID   : Could not instantiate SMBIOS table.
Error getting the Service Tag : Could not instantiate SMBIOS table.
Error getting the Product Name: Could not instantiate SMBIOS table.
Error getting the BIOS Version: Could not instantiate SMBIOS table.
Error getting the Vendor      : Could not instantiate SMBIOS table.
Is Dell:      0

Comment 1 Michael E Brown 2007-04-08 16:50:04 UTC
the sysid plugin needs to be root to access the system id. I'll add an exception
check to zero out this information if it cannot access system id.

Comment 2 Michael E Brown 2007-04-08 17:00:29 UTC
Checking sources, this bug was fixed in the already-released 1.2.10 version. 

Looking at this, I based on proposed fedora policy, I switched to arch-specific
packages for this version, and it doesnt look like yum is upgrading from noarch
-> i386.

Comment 3 Michael E Brown 2007-04-08 17:25:53 UTC
I've documented the yum bug in:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=235632

I've also created a noarch upgrade package with the latest codebase in order to
fix this problem for people who might have the older package installed.

This will be fixed in the next fedora extras push. I recommend that you remove
and re-install in order to get the .i386|x86_64 package, though.

Comment 4 Sean Stangl 2007-04-08 22:39:49 UTC
1.2.10 is now available in Fedora Extras, and the bug is resolved. However, the
noarch (1.2.6) version is also in Fedora Extras... is this intended?

Comment 5 Michael E Brown 2007-04-08 23:23:56 UTC
The fedora scripts dont automatically remove old noarch pkgs when the pkg is
converted to arch-specific. I'll have to submit a request to have it removed. In
the meantime, I've built an upgrade to 1.2.11 for the noarch version so that
nobody else accidentally hits this. It is currently waiting to be signed and
should be in the repo shortly.


Note You need to log in before you can comment on or make changes to this bug.