Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235620 - bittorrent crashing
Summary: bittorrent crashing
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: bittorrent
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 223623
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 10:14 UTC by Adam Tkac
Modified: 2013-04-30 23:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 08:55:23 UTC


Attachments (Terms of Use)

Description Adam Tkac 2007-04-08 10:14:50 UTC
Description of problem:
after while bittorent crash

Version-Release number of selected component (if applicable):
bittorrent-4.4.0-5.fc7 + bittorrent-gui-4.4.0-5.fc7

How reproducible:
always

Steps to Reproduce:
1. start bittorrent gui
2. wait about 30 minutes to crash
  
Actual results:
first, this warnings is printed:

looks like bittorrent doesn't uses recommended thread-schema
/usr/bin/bittorrent:3761: GtkDeprecationWarning: gtk.threads_init is deprecated,
use gtk.gdk.threads_init instead
  gtk.threads_init()
/usr/bin/bittorrent:2745: GtkDeprecationWarning: gtk.threads_enter is
deprecated, use gtk.gdk.threads_enter instead
  gtk.threads_enter()
/usr/bin/bittorrent:2945: GtkDeprecationWarning: gtk.threads_leave is
deprecated, use gtk.gdk.threads_leave instead
  gtk.threads_leave()
/usr/bin/bittorrent:3768: GtkDeprecationWarning: gtk.threads_enter is
deprecated, use gtk.gdk.threads_enter instead
  gtk.threads_enter()
/usr/lib/python2.5/site-packages/BitTorrent/GUI.py:28: GtkDeprecationWarning:
gtk.threads_enter is deprecated, use gtk.gdk.threads_enter instead
  gtk.threads_enter()
/usr/lib/python2.5/site-packages/BitTorrent/GUI.py:30: GtkDeprecationWarning:
gtk.threads_leave is deprecated, use gtk.gdk.threads_leave instead
  gtk.threads_leave()

bittorent crashes with this error:
The program 'bittorrent' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 7684048 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Expected results:
nice full night downloading without crash

Additional info:
I'm using x86_64 always updated rawhide but I don't think that this is 64bit
specific problem. Do you have any hints how get more debug information?

Regards, -A-

Comment 1 Paul Howarth 2007-04-09 13:43:32 UTC
The version of bittorrent in Extras is quite an old one so there's little to no
chance of this getting fixed upstream. Unfortunately the latest upstream version
has even bigger problems (see Bug #223623) and that's why we're stuck with the
old version.

The best suggestion I can offer really is either to use the curses client
(bittorrent-curses) or try one of the other GUI clients in Extras.

Comment 2 Adam Tkac 2007-04-10 08:55:23 UTC
(In reply to comment #1)
Bad news. Leave this be...


Note You need to log in before you can comment on or make changes to this bug.