Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235614 - brp-java-repack-jars redefines TMPDIR while using mktemp
Summary: brp-java-repack-jars redefines TMPDIR while using mktemp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jon Masters
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 244899
TreeView+ depends on / blocked
 
Reported: 2007-04-08 02:35 UTC by Matthew Miller
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-19 18:17:21 UTC


Attachments (Terms of Use)

Description Matthew Miller 2007-04-08 02:35:57 UTC
Description of problem:

mktemp uses the TMPDIR environment variable. The brp-java-repack-jars script
resets TMPDIR to arbitrary values that don't necessarily exist, and then tries
to use mktemp. Failures ensue.

Version-Release number of selected component (if applicable):

redhat-rpm-config-8.0.45-14.fc7

How reproducible:

intrinsic

Steps to Reproduce:
1. try to build, for example, a jpackage.org nosrc rpm
2. watch it not work.
3. there is no step three.
  
Actual results:

it fails with an error message about a temporary directory not existing.

Expected results:

it shouldn't be looking there anyway

Additional info:

replace all instances of TMPDIR in this script with something like JTMPDIR and
the problem is solved

Comment 1 Matthew Miller 2007-06-11 20:01:35 UTC
This is still a problem in current Fedora Rawhide (pre-f8, at this point), and
in RHEL5. It's an easy fix -- please make it.

Comment 2 Jeremy Katz 2007-06-19 18:17:21 UTC
Push will be fixed for rawhide later today  

Comment 3 Matthew Miller 2007-06-19 18:19:28 UTC
Thanks man. 

Comment 4 Matthew Miller 2007-06-19 18:28:58 UTC
Also, this probably deserves to get put in an update for RHEL5 eventually.

Comment 5 Jon Masters 2007-06-19 18:51:59 UTC
Cloned as a RHEL5 bug.

Jon.



Note You need to log in before you can comment on or make changes to this bug.