Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235613 - initng hangs on system/selinux/dev, system/initial failed.
Summary: initng hangs on system/selinux/dev, system/initial failed.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initng
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Malmgren
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-08 00:48 UTC by Sean Stangl
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-09 13:20:37 UTC


Attachments (Terms of Use)

Description Sean Stangl 2007-04-08 00:48:20 UTC
Description of problem:
 Booting with initng drops to the root shell (su_login), after displaying the
errors found below.

Version-Release number of selected component (if applicable):
 initng-0.6.9-3.fc6

Initng displays the following: ("..." skips irrelevant output)

system/initial/virtcheck start:
	bash_helper[system/initial/virtcheck]: line 5: /var/initng_isvirt: Read-only
file system

...

system/initial/mountvirtfs start:
	mount: proc already mounted
	mount: sys already mounted or /sys busy

12% system/udev/filldev		[done]		( done in 5286ms )

** "/builddir/build/BUILD/initng-0.6.9/plugins/service/initng_service.c",
timeout_SERVICE_START_RUN() line:559:
	20:21:31 -- WARN:	Timeout for start rpocess, service system/selinux/dev.
Killing this process now.
	system/selinux/dev	[SERVICE_START_FAILED_TIMEOUT]

** "/builddir/build/BUILD/initng-0.6.9/plugins/critical/initng_critical.c",
check_critical() line :65:
	20:21:31 -- FAIL:	Service system/initial failed, this is critical, going su_login!!

This is a sulogin offer,
you will be able to login for 2 times (now 00),
...
Give root password for maintenance (or type Control-D to continue)

Service system/mountfs/service FAILED

Comment 1 Daniel Malmgren 2007-05-07 08:36:15 UTC
Sorry for the long delay. Have you tried this on 0.6.10?

Comment 2 Daniel Malmgren 2007-05-07 09:13:53 UTC
Sorry once again. Noticed that 0.6.10 was never built for FC-6. This is now
fixed so that you can easily try with 0.6.10...

Comment 3 Sean Stangl 2007-05-08 14:16:28 UTC
Negative on 0.6.10 pushed for FC6.

Comment 4 Sean Stangl 2007-05-08 20:06:19 UTC
(In reply to comment #3)
> Negative on 0.6.10 pushed for FC6.

Err, that is, 0.6.10 has not been pushed for FC6.

Comment 5 Sean Stangl 2007-05-08 20:49:05 UTC
OK, got the update. I'm still experiencing the same error.

initng hangs after 12% system/udev/filldev for eight to ten minutes, then the
exact same error (as in the original post) is reproduced. This has been
replicated on two unrelated computers.

Comment 6 Daniel Malmgren 2007-05-09 06:35:00 UTC
Did you also upgrade initng-ifiles to latest (0.1.2-1)?

Comment 7 Sean Stangl 2007-05-09 12:50:15 UTC
Alright, I refreshed the packages and that fixes the selinux problem. However,
now, after eth0 failed due to lack of available connection, every service
thereafter began to time out, beginning with service/iptables.

I'd file this in another bug but it's just a continuation of the same.

Comment 8 Daniel Malmgren 2007-05-09 13:20:37 UTC
Ok, I'll close this bug...


Note You need to log in before you can comment on or make changes to this bug.