Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235578 - JMB363: dma_base is invalid message on boot, BUG: soft lockup detected on CPU#n message and system freeze for short time
Summary: JMB363: dma_base is invalid message on boot, BUG: soft lockup detected on CP...
Keywords:
Status: CLOSED DUPLICATE of bug 234422
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-07 14:54 UTC by Al Ricafort
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 18:59:31 UTC


Attachments (Terms of Use)

Description Al Ricafort 2007-04-07 14:54:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
On boot the system gives out the following messages:

------------------------------------------------
JMB363: BIOS configuration fixed.
JMB363: chipset revision 2
JMB363: 100% native mode on irq 16
JMB363: dma_base is invalid
ide0: JMB363 Bus-Master DMA disabled (BIOS)
JMB363: dma_base is invalid
ide1: JMB363 Bus-Master DMA disabled (BIOS)
Probing IDE interface ide0...
Probing IDE interface ide1...
JMB363: IDE controller at PCI slot 0000:03:00.1
----------------------------------------------

The system can boot without any other problem but from time to time it would freeze and when that happens it outputs a "soft lockup" error like below:

---------------------------------
BUG: soft lockup detected on CPU#1!
kernel:
kernel: Call Trace:
kernel:  <IRQ>  [<ffffffff802b1004>] softlockup_tick+0xdb/0xf6
kernel:  [<ffffffff8028f925>] update_process_times+0x42/0x68
kernel:  [<ffffffff80272084>] smp_local_timer_interrupt+0x34/0x55
kernel:  [<ffffffff80272760>] smp_apic_timer_interrupt+0x51/0x69
kernel:  [<ffffffff8025ace6>] apic_timer_interrupt+0x66/0x70
kernel:  <EOI>  [<ffffffff8031df4a>] selinux_inode_permission+0x0/0x9d
kernel:  [<ffffffff80318457>] avc_has_perm_noaudit+0xa3/0x370
kernel:  [<ffffffff80219fe2>] vsnprintf+0x55f/0x5a3
kernel:  [<ffffffff80319334>] avc_has_perm+0x28/0x58
kernel:  [<ffffffff80319f33>] inode_has_perm+0x56/0x63
kernel:  [<ffffffff802094e7>] __link_path_walk+0x178/0xdb0
kernel:  [<ffffffff8020e74f>] link_path_walk+0x55/0xd7
kernel:  [<ffffffff802159c2>] get_unused_fd+0xf9/0x107
kernel:  [<ffffffff8020c8d4>] do_path_lookup+0x1b5/0x217
kernel:  [<ffffffff8022355a>] __path_lookup_intent_open+0x56/0x97
kernel:  [<ffffffff8021a8fb>] open_namei+0x78/0x644
kernel:  [<ffffffff8022732a>] do_filp_open+0x1c/0x38
kernel:  [<ffffffff802159c2>] get_unused_fd+0xf9/0x107
kernel:  [<ffffffff80219669>] do_sys_open+0x44/0xc1
kernel:  [<ffffffff8025a11e>] system_call+0x7e/0x83
--------------------------------------------------------






Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2933.fc6

How reproducible:
Always


Steps to Reproduce:
1. Boot 
2. When the system is up and running then just wait
3.

Actual Results:


Expected Results:
No system freee.

Not sure if the "dma_base" and the "soft lockup" are related.

Additional info:
Configuration:
--------------
CPU: Intel Core 2 Duo E6400
MB: Asus P5B-VM 
1 SATA and 2 PATA Drives

Comment 1 Chuck Ebbert 2007-04-09 18:59:31 UTC

*** This bug has been marked as a duplicate of 234422 ***


Note You need to log in before you can comment on or make changes to this bug.