Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235572 - yum choose bad version for some foo-devel (in mock x86_64)
Summary: yum choose bad version for some foo-devel (in mock x86_64)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-07 13:22 UTC by Remi Collet
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version: 3.0.5-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 15:16:53 UTC


Attachments (Terms of Use)
fix potential (deleted)
2007-04-08 03:51 UTC, Seth Vidal
no flags Details | Diff

Description Remi Collet 2007-04-07 13:22:50 UTC
Seems to be a regression bug in 3.0.5 (no problem with 3.0.3).

For example, trying to build in mock a package that BR glib2-devel result in :
  Error: Missing Dependency: glib2 = 2.12.3-2.fc6 is needed by package
  glib2-devel

Running with yum debuglvel=9 give more information

When Executing /usr/sbin/mock-helper yum --installroot
  /var/lib/mock/fc6/root resolvedep   'glib2-devel >= 2.0.3' ...

  Searching pkgSack for dep: glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.3-2.fc6.i386
  Matched glib2-devel - 2.12.3-2.fc6.i386 to require for glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.9-1.fc6.i386
  Matched glib2-devel - 2.12.9-1.fc6.i386 to require for glib2-devel
  0:glib2-devel-2.12.9-1.fc6.i386

That's seems OK

But when  Executing /usr/sbin/mock-helper yum --installroot
  /var/lib/mock/fc6/root install  'glib2-devel >= 2.0.3' ...

  Searching pkgSack for dep: glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.3-2.fc6.i386
  Matched glib2-devel - 2.12.3-2.fc6.i386 to require for glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.9-1.fc6.i386
  Matched glib2-devel - 2.12.9-1.fc6.i386 to require for glib2-devel
  No other glib2-devel installed, adding to list for potential install
  Solving package glib2-devel - 2.12.3-2.fc6.i386 is installable, not
going through the rest

This occurs when building from FC6 x86_64.

Full (very big) log : http://remi.collet.free.fr/files/root.log

Thanks for help.

Comment 1 Seth Vidal 2007-04-07 15:56:19 UTC
rpm -q yum

I need to know the specific version-release of 3.0.5 from fc6 on this, please.

Comment 2 Remi Collet 2007-04-07 16:53:09 UTC
The one from "updates" repository : yum-3.0.5-1.fc6

Do you want me to test yum-3.0.5-2.fc6 from testing ?


Comment 3 Remi Collet 2007-04-07 17:03:04 UTC
Same issue with yum-3.0.5-2 from "updates-testing"

Full log (debuglevel=9) : http://remi.collet.free.fr/files/root2.log



Comment 4 Seth Vidal 2007-04-08 03:51:03 UTC
Created attachment 151925 [details]
fix potential

Comment 5 Seth Vidal 2007-04-08 03:52:00 UTC
please test the attached patch. I think it fixes the problem and hopefully
doesn't create more ;)


Comment 6 Jonathan Steffan 2007-04-08 04:14:28 UTC
Fixes the issue(s) I have been having related to this bug.

Comment 7 Remi Collet 2007-04-08 08:09:26 UTC
No more problem with yum-3.0.5-2 + yum-install-by-dep-fix.patch.

Good fixe.
Thanks.

Comment 8 Jeremy Katz 2007-04-09 15:16:53 UTC
3.0.5-2 should be going out as a final update now today.


Note You need to log in before you can comment on or make changes to this bug.