Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235560 - Many SM errors in apache logs
Summary: Many SM errors in apache logs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: squirrelmail
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-07 09:07 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 17:19:17 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2007-04-07 09:07:07 UTC
[Fri Apr 06 11:38:59 2007] [error] [client 192.54.193.51] PHP Warning: 
preg_split() expects parameter 4 to be long, string given in
/usr/share/squirrelmail/function
s/imap_messages.php on line 808, referer:
https://rousalka.dyndns.org/src/read_body.php?passed_id=96147&mailbox=Technique.Fedora&sort=6&startMessage=1&show_more=0&de
lete_id=96146
[Fri Apr 06 11:38:59 2007] [error] [client 192.54.193.51] PHP Warning:  Invalid
argument supplied for foreach() in /usr/share/squirrelmail/functions/mime.php on
line
 52, referer:
https://rousalka.dyndns.org/src/read_body.php?passed_id=96147&mailbox=Technique.Fedora&sort=6&startMessage=1&show_more=0&delete_id=96146
[Fri Apr 06 11:42:08 2007] [error] [client 192.54.193.51] PHP Notice:  Undefined
variable: charset_converted in /usr/share/squirrelmail/functions/mime.php on line 31
6, referer:
https://rousalka.dyndns.org/src/right_main.php?sort=6&startMessage=1&mailbox=Technique.Fedora
[Fri Apr 06 11:42:08 2007] [error] [client 192.54.193.51] PHP Notice:  Undefined
variable: charset in /usr/share/squirrelmail/functions/mime.php on line 317, referer
:
https://rousalka.dyndns.org/src/right_main.php?sort=6&startMessage=1&mailbox=Technique.Fedora



# rpm -V squirrelmail
S.5....T c /etc/httpd/conf.d/squirrelmail.conf
S.5....T c /etc/squirrelmail/config.php

$ rpm -q php httpd squirrelmail
php-5.2.1-5.x86_64
httpd-2.2.4-2.x86_64
squirrelmail-1.4.8-4.fc6.noarch

Comment 1 Tomas 2007-04-12 05:51:12 UTC
Duplicate to 229454

Comment 2 Nicolas Mailhot 2007-04-12 05:58:43 UTC
*** Bug 229454 has been marked as a duplicate of this bug. ***

Comment 3 Tomas 2007-04-12 06:10:32 UTC
:) #229454 bug is older and has more comments than this report. If you want to
close it upstream, please explain issue you are trying to solve with
formatBody() function modifications.

SendDownloadHeaders() issue is already reported on SquirrelMail i18n bug
tracker. Your fix does not cover Chinese and Korean.

Comment 4 Nicolas Mailhot 2007-04-12 07:24:03 UTC
(In reply to comment #3)
> :) bug #229454 is older and has more comments than this report. 

I know.
However from a practical POW bugs targetting a distribution release in beta
phase stand a better chance to be fixed than bugs targetting a release ending
its lifecycle.

Friendly hint: always check if bugs affect Fedora Devel, and make them block
FCXTarget or FCXBlocker

Comment 5 Martin Bacovsky 2007-04-17 17:19:17 UTC
This issue should be "solved" in rawhide in squirrelmail-1.4.9a-1.fc7. As for
now I intialized variables causing error messages. Patch
squirrelmail-1.4.8-IE-Japanese-download-ugly-hack.patch which is responsible for
those messages looks wierd. It will take me some more time to find nicer
solution for this issue because I'm unable to reproduce the bug patch should be
fixing yet. 

I reopened #229454 for further investigation and better fix of this.


Note You need to log in before you can comment on or make changes to this bug.