Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235552 - Software Updater entered unhandled exception
Summary: Software Updater entered unhandled exception
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-07 04:48 UTC by Ganapathi Kamath
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-13 12:59:27 UTC


Attachments (Terms of Use)
dump from software updater (deleted)
2007-04-07 04:48 UTC, Ganapathi Kamath
no flags Details

Description Ganapathi Kamath 2007-04-07 04:48:20 UTC
Description of problem:
Software updated enterred unhandled exception while updating packages
on fedora-core-7-test-3. The dialog box suggested that I save dump
and file bug in against "Software updater" component (which I could not find
, please transfer as appropriate)
Dump attached

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ganapathi Kamath 2007-04-07 04:48:20 UTC
Created attachment 151906 [details]
dump from software updater

Comment 2 Ganapathi Kamath 2007-04-07 22:18:52 UTC
The rpm db has corrupted
ls -l /var/lib/rpm/__db*
-rw-r--r-- 1 root root       0 2007-04-07 17:01 /var/lib/rpm/__db.000
-rw-r--r-- 1 root root   24576 2007-04-07 16:48 /var/lib/rpm/__db.001
-rw-r--r-- 1 root root 1318912 2007-04-07 16:48 /var/lib/rpm/__db.002
-rw-r--r-- 1 root root  450560 2007-04-07 16:48 /var/lib/rpm/__db.003

Happens during update of nfs-utils

Update details
nfs-utils - 1:1.0.12-4.fc7.i386 updates nfs-utils - 1:1.0.12-3.fc7.i386

The Following get added
Adding for dependencies:
libtirpc-0.1.7-5.fc7
rpcbind-0.1.4-2.fc7

Other info
[root@localhost mnt]# rpm -qa | grep rpc
[root@localhost mnt]# rpm -qa | grep glibc-common
glibc-common-2.5.90-19
glibc-common-2.5.90-20

workaround 
don't install nfsutils

workaround to repair db
#rm -f /var/lib/rpm/__db*
#rpm --rebuilddb

Check for glibc installation
[root@localhost mnt]# rpm -qa | grep glibc | sort
glibc-2.5.90-19
glibc-2.5.90-20
glibc-common-2.5.90-19
glibc-common-2.5.90-20
glibc-devel-2.5.90-19
glibc-devel-2.5.90-20
glibc-headers-2.5.90-19
glibc-headers-2.5.90-20


Get rid of the old glibc directories
[root@localhost mnt]# rpm -e glibc-devel-2.5.90-19
[root@localhost mnt]# rpm -e glibc-headers-2.5.90-19
[root@localhost mnt]# rpm -e glibc-2.5.90-19
/var/tmp/rpm-tmp.23467: line 3:  9796 Segmentation fault  
/usr/sbin/redhat_lsb_trigger.i386         ???? something fishy
[root@localhost mnt]# rpm -e glibc-common-2.5.90-19
[root@localhost mnt]# rpm -e glibc-2.5.90-19
error: package glibc-2.5.90-19 is not installed
[root@localhost mnt]# rpm -qf /usr/sbin/rpcinfo 
error: file /usr/sbin/rpcinfo: No such file or directory



Perhaps related to Bug 228894
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=228894










Comment 3 Panu Matilainen 2007-08-13 12:59:27 UTC
Fixed since rpm >= 4.4.2.1-1 in rawhide and soon F7 + FC6, python processes
tracebacking while accessing rpmdb no longer leave stale locks (and other
corruption) behind.


Note You need to log in before you can comment on or make changes to this bug.