Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235547 - gnome session slow start, hangs after starting metacity
Summary: gnome session slow start, hangs after starting metacity
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 5
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-07 00:02 UTC by henri Michel
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-18 18:33:59 UTC


Attachments (Terms of Use)
home dir of user joe (should be /home/joe) (deleted)
2007-04-07 00:02 UTC, henri Michel
no flags Details

Description henri Michel 2007-04-07 00:02:06 UTC
Description of problem:
Starting gnome : the splash screen will be frozen for a while displaying
starting metacity" it will then timeout and proceed.

This is clearly related to failure of metacity to respond (or register), (gnome
session will start faster when using --purge-delay --wait-delay gnome-session
options)

An easy fix is to remove ~/.gnome2/session file : something which seems quite
hairy for a novice user.
In general rewriting ~/.gnome2/session if preferences->session->saving session
is enabled will fix the problem. Unfortunately this is not the default setting.

Version-Release number of selected component (if applicable):
FC5 with all updates applied as of today gnome-session-2.14.3-1.fc5, but maybe
the problem is not in gnome-session but in gconf or other gnome services.

How reproducible:
I was able to reproduce the pb with
- an empty /tmp (god only knows the details of all sockets, that gnome leaves
behind in /tmp :-) without caring to clean up
. a minimal home directory (3 files !!!) in attached tar file
. I got the same behavior on a second PC (which is not a clone of my laptop)
which was kickstarted and all updates applied (yum -y update)

Steps to Reproduce:
1.adduser joe
2.cd ~joe 
3.remove all
4. tar xpzf TGZ_IN_ATTACHEMENT
  
Actual results:
starting a gnome session as user joe will cause a long hang before being able to
enter the gnome session

Expected results:


Additional info: file .gnome2/session.ok is what I got after changing settings
to save session (and minimal editing to have the same .metacity/sessions/*.ms
So .gnome2/session.ok should convey the same info as .gnome2/session (only the
order in the session file and the ids change)
But - with .gnome2/session starting session is *very* long
    . after cp /home/joe/.gnome2/session{.ok,} starting gnome session is real fast
Can you reproduce the pb?, I would be happy to help debugging, I just started
strace on the full gnome-session (this is painful) don't even know whose fault
it is (gnome-session, metacity, gconfd.. gnome-settings ...)

Comment 1 henri Michel 2007-04-07 00:02:06 UTC
Created attachment 151903 [details]
home dir of user joe (should be /home/joe)

Comment 2 Ray Strode [halfline] 2008-03-18 18:33:59 UTC
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)


Note You need to log in before you can comment on or make changes to this bug.