Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235545 - utrace: ptrace operations should work on child in job control stop
Summary: utrace: ptrace operations should work on child in job control stop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Roland McGrath
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On: 235521
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-06 22:02 UTC by Roland McGrath
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:46:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Roland McGrath 2007-04-06 22:02:09 UTC
+++ This bug was initially created as a clone of Bug #235521 +++

Description of problem:
Found a regression against kernel.org in RH kernels utrace based implementation
of ptrace(2).

See bug 235521 for test case and details.

Comment 1 RHEL Product and Program Management 2007-04-06 22:25:21 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 4 RHEL Product and Program Management 2007-06-20 12:31:26 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 5 Don Zickus 2007-07-19 21:01:15 UTC
in kernel-2.6.18-30.el5

Comment 7 Mike Gahagan 2007-08-28 20:21:14 UTC
[root@test183 tests]# diff out.2.6.18-*
18c18
< PASS: frysk4330/stopkills
---
> FAIL: frysk4330/stopkills
[root@test183 tests]# echo diff out.2.6.18-*
diff out.2.6.18-43.el5 out.2.6.18-8.el5

the failure mode according to strace is the ptrace(PTRACE_DETACH,...) call is
failing with a -ESRCH (No such process), with the -8 kernel. Exits cleanly with
the -43 kernel



Comment 9 errata-xmlrpc 2007-11-07 19:46:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.