Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235520 - new packages installation failed with yum
Summary: new packages installation failed with yum
Keywords:
Status: CLOSED DUPLICATE of bug 212180
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum
Version: 5.0
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-06 17:34 UTC by guolin
Modified: 2013-01-10 10:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 15:15:59 UTC


Attachments (Terms of Use)

Description guolin 2007-04-06 17:34:18 UTC
Description of problem:

 After a RHEL5 machine is installed, a command 'yum install <anyPackage>' 
failed with error messages:

 error was [Errno 4] IOError: <urlopen error unknown url type: media>


Version-Release number of selected component (if applicable):

 yum-3.0.1-5.el5.noarch

How reproducible:

  Every time.

Steps to Reproduce:

1. extract the default RHEL5 Client ISOs into a same directory according to 
README, then install a RHEL5 computer with either kickstart or interactive 
method. 

2. setup yum repositories definition files and put them 
under /etc/yum.repos.d/. Client, VT and Workstation directories have their own 
definitions. I've named the three files redhatClient.repo, redhatVT,repo, 
redhatWorkstation.repo. They are pretty similar and one of them is like this:

pullmyhair@restRHEL5 ~]$ cat /etc/yum.repos.d/redhatClient.repo 
[baseClient]
name=Redhat Enterprise $releasever - $basearch - Base - Client
baseurl=http://RHEL5Server.example.com/<path-to-RHEL5-extracted-ISOs-
tree>/Client/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
pullmyhair@testREHL5 ~]$ 


3. Then run 'yum install <anyPackageOrAnyGroup>' command to install additional 
package(s). The yum command will fail every time.
  
Actual results:

[root@testRHEL5 ~]# yum install gnuplot
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
baseClient                100% |=========================| 1.3 kB    00:00     
baseVT                    100% |=========================| 1.3 kB    00:00     
baseWorkstation           100% |=========================| 1.3 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 508 kB    00:00     
################################################## 1512/1512
primary.xml.gz            100% |=========================| 6.0 kB    00:00     
################################################## 31/31
primary.xml.gz            100% |=========================| 218 kB    00:00     
################################################## 734/734
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gnuplot to pack into transaction set.
media://1170972087.594754%232/gnuplot-4.0.0-12.i386.rpm: [Errno 4] IOError: 
<url
open error unknown url type: media>
Trying other mirror.
Error: failed to retrieve gnuplot-4.0.0-12.i386.rpm from baseClient
error was [Errno 4] IOError: <urlopen error unknown url type: media>
[root@testRHEL5 ~]#


Expected results:


Additional info:

1, If I rename all the repodata/ directory to repodata_ORIG/ under 
Client/VT/Workstation directories of the extracted original RHEL5 ISOs, then 
run 'createrepo . ' to re-generate new repodata/ tree. Then the yum command 
works. 

But Since it is a change of the default original installation tree, It poses a 
big question mark there whether, and how serious, the anaconda and kickstart 
will be affected.

Comment 1 Jeremy Katz 2007-04-09 15:15:59 UTC
anaconda has support for the media:// bits in URLs, yum doesn't as shipped in
RHEL5.  

*** This bug has been marked as a duplicate of 212180 ***


Note You need to log in before you can comment on or make changes to this bug.