Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235514 - Fonts garbled when connecting to Windows XP, Windows Server 2003
Summary: Fonts garbled when connecting to Windows XP, Windows Server 2003
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rdesktop
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-06 15:41 UTC by Jonathan Kamens
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 12:28:59 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2007-04-06 15:41:11 UTC
When I use rdesktop (current devel as well as FC6) to connect to a Windows XP or
Windows Server 2003 machine, lots of my fonts on the other end are garbled --
weird characters, blank spaces, or boxes display instead of the correct font
characters.

When I connect to the same machines using the Microsoft terminal services client
from inside VMware, everything is fine, so I don't think the problem is at the
other end.

Because I don't believe this started happening until recently, and because it
happens with both the current (1.5) and old (1.4) version of rdesktop, I am
wondering if perhaps the problem is not rdesktop but rather is the X server. 
I'm using current Fedora Devel versions of all the X RPMs, with the Via
unichrome driver.

Comment 1 Jonathan Kamens 2007-04-16 12:28:59 UTC
Something in the Rawhide packages current as of yesterday has fixed this issue.
 At least, I can no long reproduce it.  I'll reopen if it comes up again.


Note You need to log in before you can comment on or make changes to this bug.