Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235507 - rpmbuild -bs should not check dependencies
Summary: rpmbuild -bs should not check dependencies
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-06 14:03 UTC by Zenon Panoussis
Modified: 2008-07-14 11:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 11:47:26 UTC


Attachments (Terms of Use)

Description Zenon Panoussis 2007-04-06 14:03:18 UTC
Description of problem:
rpmbuild -bs util-linux.spec
error: Failed build dependencies:
         e2fsprogs-devel >= 1.36 is needed by (etc, etc)


Version-Release number of selected component (if applicable):
rpm-build-4.4.2-32


Expected results:
-bs should not check for buildrequires.

 
Additional info:
I don't remember running into this behaviour in earlier versions, so 
I suspect it's new.

Comment 1 Jeff Johnson 2007-04-07 02:01:14 UTC
Add --nodeps if you don't wish dependencies checked.

Add to /etc/popt
    rpmbuild alias --bs -bs --nodeps
to add --nodeps persistently.

WORKSFORME

Comment 2 Zenon Panoussis 2007-04-07 14:07:01 UTC
Of course --nodeps is the obvious and simple workaround, but there is no reason
why it should be necessary in the first place. Source rpms have no build
dependencies, ever, so rpm should not claim they do. Therefore, I think, it
would be more elegant and more correct if rpm itself implied --nodeps to -bs,
rather than confront the user with false dependencies and require him to negate
them. 



Comment 3 Jeff Johnson 2007-04-07 14:15:04 UTC
We disagree (at least until the build state machine changes to produce a srpm earlier).

Add the popt alias and be happy.

Comment 4 Zenon Panoussis 2007-04-08 05:25:10 UTC
(In reply to comment #3)

Thank you for the hint, but I wasn't trying to configure my system here; I was
suggesting a general improvement. If a popt alias is the solution to this
regression for me, then adding a popt_alias.patch to the rpm package should be
the solution for everybody. 

Then again, having read the entire mailing list^w^wbug #174307 and all the links
from it to elsewhere, I believe there is no point in arguing anything at all on
this subject. If you can close this bug with DONTCARE_&_WONTFIX, please do. As
for me being happy or not, I think it's beyond the scope of any bug report.



Comment 5 Jeff Johnson 2007-04-09 13:14:52 UTC
The correct (imho) fix is to produce a srpm immediately after parsing, and
drive a build from a srpm header.

The net effect will be that dependencies are not checked when using -bs.

Comment 6 Red Hat Bugzilla 2007-08-21 05:33:13 UTC
User pnasrat@redhat.com's account has been closed

Comment 7 Panu Matilainen 2007-08-22 06:35:21 UTC
Reassigning to owner after bugzilla made a mess, sorry about the noise...

Comment 8 Panu Matilainen 2007-08-30 07:31:45 UTC
Moving to devel to avoid "timeouting", the issue is deeper than it looks like as
explained in comments 3 and 5.

Comment 9 Rasmus Ory Nielsen 2007-09-20 07:19:28 UTC
BTW, the --nodeps option is not mentioned in the man pages, only in rpmbuild --help

Comment 10 Stephen Warren 2008-04-17 21:28:43 UTC
I also figure this is a bug, and would like to "vote" to fix it.

In my case: rpm-build-4.4.2-47.el5.i386

It took a few pages of scrolling through google to find this bug report, and
associated work-around. I never would have even though rpmbuild *had* a --nodeps
option, because such an option doesn't make any sense for a -bb, so why have it?


Comment 11 Bug Zapper 2008-05-14 02:44:37 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Panu Matilainen 2008-07-14 11:47:26 UTC
The new rpm in rawhide no longer checks for dependencies when building just src.rpm.


Note You need to log in before you can comment on or make changes to this bug.