Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235502 - SMC nic mac lost after booting kernel-xen / xend
Summary: SMC nic mac lost after booting kernel-xen / xend
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Xen Maintainance List
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks: 514491
TreeView+ depends on / blocked
 
Reported: 2007-04-06 12:27 UTC by Joshua M. Hoffman
Modified: 2010-06-22 18:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-22 18:53:09 UTC


Attachments (Terms of Use)

Description Joshua M. Hoffman 2007-04-06 12:27:26 UTC
Description of problem:

After booting kernel-xen and starting xend with a default config, my nic's mac
becomes locked to FF:FE:FF:FF:FF:FF.  Booting back to non-xen kernel does not
help.  The "broken" mac is still there, even when I PXE boot from bios.

The only way I have found to fix the problem is to remove and re-seat the nic.

I have a lab of 15 of the same machines all having this problem.


Version-Release number of selected component (if applicable):

RHEL5 (2.6.18-8.el5xen)
SMC pci card model: SMC1255TX
SMC optional boot rom installed: SMC1255B-ROM V1.23


How reproducible:

Almost every time.  Fails to occur only rarely.


Steps to Reproduce:

1. Install said nic w/ optional boot rom (as eth0)
2. Boot kernel-xen
3. Reboot to non-xen kernel

  
Actual results:

MAC = FF:FE:FF:FF:FF:FF


Expected results:

MAC = <NORMAL MAC>


Additional info:

Computers are all Dell Optiplex GX280 "n" series
Bios revision A08

Note: On these machines the SMC pci is eth0 (built-in is eth1). The problem does
not occur with built-in nic (if pci is removed and built-in is used as eth0).

I'll be happy to ship one of these nics to someone, if desired.

Comment 1 Red Hat Bugzilla 2007-07-25 00:44:52 UTC
change QA contact

Comment 5 Andrew Jones 2010-06-22 17:06:00 UTC
I have a feeling this isn't a problem any more, since it's been quite for 3 years. Joshua, can you confirm that this is no longer an issue?

Comment 6 Joshua M. Hoffman 2010-06-22 18:46:50 UTC
It is no longer a problem for me as I do not have any SMC1255TXs in service and have not for some time.

Comment 7 Andrew Jones 2010-06-22 18:53:09 UTC
The only reporter of this bug is no longer affected by it. I'll close it out, if somebody comes across it and has the same issue, then they can feel free to reopen.

Andrew


Note You need to log in before you can comment on or make changes to this bug.