Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235488 - blender shows display artifacts
Summary: blender shows display artifacts
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-06 07:15 UTC by Dean Brettle
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-05 17:23:39 UTC


Attachments (Terms of Use)
Screenshot showing artifacts (deleted)
2007-04-06 07:15 UTC, Dean Brettle
no flags Details

Description Dean Brettle 2007-04-06 07:15:16 UTC
Description of problem:

The blender UI has multiple artifacts even when desktop effects and hardware
acceleration is disabled.  Artifacts include: the bottom buttons are not shown
unless I roll the mouse over them, the top menu sometimes disappears, and the
modelling window leaves traces when things are rotated, etc.  

Version-Release number of selected component (if applicable):
blender-2.42a-18.fc7

How reproducible:

Always.

Steps to Reproduce:
1. Boot from fc7-test3-live-i386 CD.
2. yum -y install blender
3. blender
4. drag the middle-button in the main window.
  
Actual results:

Aforementioned artifacts (see attached screenshot).

Expected results:

No artifacts. :-)

Additional info:

My Xorg.0.log files says I have the following graphics card:

(--) PCI:*(1:0:0) ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] rev 0,
Mem @ 0xe0000000/27, 0xed000000/16, I/O @ 0xa000/8

The problem does not exist when using the FC6-Zod-Live-i386 CD on the same system.

None of the following fixed the problem under f7-test3-i386:

1. Using: LIBGL_ALWAYS_INDIRECT=1 blender
2. Using driconf to "Disabled 3D Acceleration".
3. Upgrading to xorg-x11-server-Xorg-1.2.99.903-2.fc7 (and logging back in).
4. Replacing blender with the FC6 version (i.e. blender-2.42a-4.fc6.i386.rpm). 
  I had to make some library symlinks to do that test but I got the same artifacts.

glxgears works fine.

Problem also occurs when using f7-test3-live-x86_64.

Comment 1 Dean Brettle 2007-04-06 07:15:16 UTC
Created attachment 151857 [details]
Screenshot showing artifacts

Comment 2 Jochen Schmitt 2007-06-21 18:30:20 UTC
Question:

1.) Doens occured the issue anymore.
2.) If yes, ic the issue occured when you disables the desktop effects.

Comment 3 Dean Brettle 2007-06-22 08:29:23 UTC
I just tried with the final fedora 7 live cd (i386) and the problem still
occurs.  My machine hung when trying to apply all updates after booting from the
CD, so I wasn't able to test with all updates applied.

I did not explicitly enable desktop effects, and I think they are disabled by
default, so I believe the answer to your second question is "yes".


Comment 4 Jochen Schmitt 2007-07-05 17:23:39 UTC
I have create Bug #6912 on the Blender bug tracking system, but I don't assume a
solution for the reported issue.

Comment 5 Jochen Schmitt 2007-07-23 15:56:01 UTC
Upstream wrote, that the issue will caused by the poor OpenGL support of ATI
grapic cards.



Note You need to log in before you can comment on or make changes to this bug.