Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235467 - cpp crash with -Wmissing-include-dirs
Summary: cpp crash with -Wmissing-include-dirs
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 22:31 UTC by Behdad Esfahbod
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-14 17:53:58 UTC


Attachments (Terms of Use)

Description Behdad Esfahbod 2007-04-05 22:31:15 UTC
Description of problem:

I use a lot of warning flags and I've been seeing gcc crash building firefox and
freetype (but not many other projects I build).  Anyway, I have tracked it down
to -Wmissing-include-dirs and a minimal test case.  Should be something very silly.


Version-Release number of selected component (if applicable):

cpp-4.1.1-51.fc6


Steps to Reproduce:
1. Create a file named x.c containing one line:

        #include "x.h"

2. Run:

        cpp -Wmissing-include-dirs -Ixx x.c
  
Actual results:

cc1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.


Expected results:

# 1 "x.c"
# 1 "<built-in>"
# 1 "<command line>"
# 1 "x.c"
x.c:1:22: error: x.h: No such file or directory

Comment 1 Jakub Jelinek 2007-04-06 08:16:41 UTC
Sorry, can't reproduce this, with either cpp-4.1.1-51.fc6 on ppc32
or cpp-4.1.1-52.el5.1 on x86_64.
All I get is:
cpp -Wmissing-include-dirs -Ixx x.c
cc1: warning: xx: No such file or directory
# 1 "x.c"
# 1 "<built-in>"
# 1 "<command line>"
# 1 "x.c"
x.c:1:15: error: x.h: No such file or directory



Note You need to log in before you can comment on or make changes to this bug.