Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235454 - package installation inconsistencies
Summary: package installation inconsistencies
Keywords:
Status: CLOSED DUPLICATE of bug 280101
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 21:15 UTC by Need Real Name
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-11 20:03:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
.tar file of rpm-qa listing for 2 systems (deleted)
2007-04-05 21:15 UTC, Need Real Name
no flags Details

Description Need Real Name 2007-04-05 21:15:26 UTC
Description of problem:
%package inconsistencies
Reusing anaconda.ks.cfg on a 2nd system results in different packages installed
than original system.
Version-Release number of selected component (if applicable):
RHEL5 Client

How reproducible:
Always

Steps to Reproduce:
1.Install via linux ask method to nfs mounted sources
2.Selection packages manually
3.Reuse anaconda.ks.cfg on 2nd system
  
Actual results:
rpm-qa > system1 differs rpm-qa > system2


Expected results:
rpm-qa > system1 no diffs rpm-qa system2

Additional info:

Comment 1 Need Real Name 2007-04-05 21:15:26 UTC
Created attachment 151810 [details]
.tar file of rpm-qa listing for 2 systems

Comment 2 Chris Lumens 2007-04-10 21:05:52 UTC
What do the kickstart files generated from the first install and second install
look like?

Comment 3 Gregory Bird 2007-04-12 20:33:27 UTC
I can reproduce this 100% of the time with RHEL5 Server and the following steps.

1. Install via NFS mounted sources.
2. Keep all default packages, but add system-config-kickstart.  System reboots
with working X.
3. Open anaconda-ks.cfg in system-config-kickstart and save-as "ks.cfg".  This
changes the format of the file.
4. Reinstall RHEL5 Server on the same machine using "ks.cfg" via http.  System
is missing at least xorg-x11-xinit therefore no X.

The packages section looks like this before and after system-config-kickstart
----------------------------------------------------------------------
%packages
@admin-tools
----------------------------------------------------------------------


Comment 4 Need Real Name 2007-04-18 18:30:19 UTC
This may be going on in rhel4 as well, 
here are the package list sections of 2 ks files from our rhel4 installs
1st is from the ks file we use to build the system
2nd is the anaconda.ks.cfg file from the system after it's built

1st
%packages
@ kde-software-development
@ office
@ kde-desktop
@ x-software-development
@ legacy-software-development
@ authoring-and-publishing
@ gnome-desktop
@ dialup
@ system-tools
@ sound-and-video
@ editors
@ emacs
@ admin-tools
@ base-x
@ printing
@ gnome-software-development
@ graphics
@ development-tools
@ engineering-and-scientific
@ text-internet
@ graphical-internet
am-utils
kernel
lvm2
grub
kernel-devel
e2fsprogs
subversion
gftp
gsl
gtk+-devel
glib-devel
postgresql
postgresql-contrib
postgresql-devel
postgresql-docs
postgresql-jdbc
postgresql-libs
postgresql-odbc
postgresql-pl
postgresql-python
postgresql-tcl
ruby
ruby-devel
ruby-libs
ruby-mode
unixODBC
unixODBC-devel

2nd
%packages
@ kde-software-development
@ office
@ kde-desktop
@ x-software-development
@ legacy-software-development
@ authoring-and-publishing
@ gnome-desktop
@ dialup
@ system-tools
@ sound-and-video
@ editors
@ emacs
@ admin-tools
@ emacs
@ base-x
@ printing
@ gnome-software-development
@ graphics
@ development-tools
@ engineering-and-scientific
@ text-internet
@ graphical-internet
grub
e2fsprogs
kernel-smp
kernel-smp-devel

Comment 5 Chris Lumens 2007-09-11 20:03:20 UTC

*** This bug has been marked as a duplicate of 280101 ***


Note You need to log in before you can comment on or make changes to this bug.