Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235444 - benq 5000 scanner no longer works on FC6
Summary: benq 5000 scanner no longer works on FC6
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane
Version: 6
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: David Lawrence
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2007-04-05 19:49 UTC by Aldy Hernandez
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-05-06 19:28:21 UTC

Attachments (Terms of Use)

Description Aldy Hernandez 2007-04-05 19:49:28 UTC
Description of problem:
The Benq 5000 scanner fails on FC6.  The scanner warms up ok, and pressing
"Scan" makes some noises in the scanner, but then fails with:

   Failed to start scanner: Error during device I/O

I have tried both as root and as a plain user.  I also have my firmware.bin in
/usr/share/sane/snapscan/.  This scanner worked perfectly under FC5.

Version-Release number of selected component (if applicable):

How reproducible:
Every time.

Steps to Reproduce:
1. Press "Scan" in xsane.
Actual results:
Failed to start scanner: Error during device I/O

Expected results:
A scan.

Additional info:

Comment 1 Nils Philippsen 2007-04-26 06:45:38 UTC
I'm a bit doubtful that it helps (it's only the frontend), but have you seen the
problem with the current xsane-0.994-2.fc67 as well?

Comment 2 Aldy Hernandez 2007-04-26 09:52:29 UTC
I just updated, and it makes no difference.

Interestingly, the first time I run xsane now it gives me the same error as
always.  The second time, it can't even find the scanner device.  Resetting the
scanner brings it back to the usual error upon running xsane yet again.

Let me know if there's anything else I can do to help.

Comment 3 Nils Philippsen 2007-06-13 07:48:34 UTC
Aldy, sorry for taking so long ;-). Please try whether you can get it to work
with the old FC5 kernel (in case there have been USB changes contributing to the

Comment 4 Heber Vazquez 2007-06-30 20:57:55 UTC
  Hi Aldy, and thanks for your e-mail response.

  I found in a ubuntu forum that the problem is caused by "USB selective
suspend/resume and wakeup (EXPERIMENTAL)" on the kernel code.  I recompile my
kernel (F7 amd_x64, Benq3300U scanner) without this option and now is working
without problems... 

by the way, I optimize my cpu to amd 64 and ntfs RW on kernel code :)

Comment 5 Nils Philippsen 2007-07-16 19:46:33 UTC
Aldy, I suspect that this is a duplicate of bug 243953.

Please try whether _one_ of the following fixes the problem:

a) with a current FC6/F7 kernel, add "usbcore.autosuspend=0" without the quotes
to the kernel command line, reboot

b) install kernel version 2.6.21-1.3255.fc7 from updates-testing and reboot into


Comment 6 Bug Zapper 2008-04-04 06:47:05 UTC
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out

Comment 7 Bug Zapper 2008-05-06 19:28:19 UTC
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.