Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235441 - ip=dhcp seems to be inverted
Summary: ip=dhcp seems to be inverted
Keywords:
Status: CLOSED DUPLICATE of bug 244418
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On: 233152
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 19:24 UTC by David Cantrell
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-21 19:51:05 UTC


Attachments (Terms of Use)

Description David Cantrell 2007-04-05 19:24:28 UTC
+++ This bug was initially created as a clone of Bug #233152 +++

If I boot rawhide with 'ip=dhcp ks=[url]' on the commandline, my system does not
attempt dhcp, and fails to retrieve the kickstart.

If I boot without 'ip=dhcp', the system *does* perform a DHCP request, gets an
address, and happily continues.

This is with anaconda-11.2.0.38, from today's rawhide.

-- Additional comment from dcantrell@redhat.com on 2007-03-21 17:08 EST --
Figured it out.  Here's the patch:

RCS file: /usr/local/CVS/anaconda/loader2/loader.c,v
retrieving revision 1.233
diff -u -p -r1.233 loader.c
--- loader.c    14 Mar 2007 20:24:47 -0000      1.233
+++ loader.c    21 Mar 2007 21:04:08 -0000
@@ -514,7 +514,7 @@ static void parseCmdLineIp(struct loader
     start = argv + 3;
     end = strstr(start, ":");
     loaderData->ip = strndup(start, end-start);
-    loaderData->ipinfo_set = 1;
+    loaderData->ipinfo_set = 0;
 
     /* Boot server */
     if (end + 1 == '\0')
@@ -542,7 +542,7 @@ static void parseCmdLineIp(struct loader
     loaderData->netmask = strdup(start);
   } else {
     loaderData->ip = strdup(argv + 3);
-    loaderData->ipinfo_set = 1;
+    loaderData->ipinfo_set = 0;
   }
 }

I love loader.  Fixed in anaconda CVS, closing as rawhide.  Will appear in the
next anaconda build.  You know the drill.

Comment 1 Chris Lumens 2007-06-21 19:51:05 UTC
Duping to a future bug that already has all the ACKs we need to get this fix in.

*** This bug has been marked as a duplicate of 244418 ***


Note You need to log in before you can comment on or make changes to this bug.