Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235436 - two files in devel packge that should be in main package
Summary: two files in devel packge that should be in main package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lftp
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Maros Barabas
QA Contact:
URL:
Whiteboard:
: 235503 235559 235911 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-05 19:01 UTC by Thorsten Leemhuis
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-14 05:45:59 UTC


Attachments (Terms of Use)

Description Thorsten Leemhuis 2007-04-05 19:01:05 UTC
Description of problem:
Installing lftp tracks in devel package; that should not be needed, lftp should
work on its own without the devel subpackge. Only the *.so files should be in
the devel package, not the *.so.* files

Version-Release number of selected component (if applicable):
lftp-3.5.10-2.fc7

How reproducible:
always

Steps to Reproduce:
$ LC_ALL=C sudo rpm -ivh lftp-3.5.10-2.fc7.x86_64.rpm 
error: Failed dependencies:
        liblftp-jobs.so.0()(64bit) is needed by lftp-3.5.10-2.fc7.x86_64
        liblftp-tasks.so.0()(64bit) is needed by lftp-3.5.10-2.fc7.x86_64
$ LC_ALL=C sudo rpm -ivh lftp-3.5.10-2.fc7.x86_64.rpm
lftp-devel-3.5.10-2.fc7.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:lftp-devel             ########################################### [ 50%]
   2:lftp                   ########################################### [100%]
error reading information on service lftp: No such file or directory
$

Additional info:
the "error reading information on service lftp: No such file or directory"
should be fixed as well.

Comment 1 Jeremy Katz 2007-04-09 21:46:02 UTC
*** Bug 235503 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2007-04-09 21:46:18 UTC
*** Bug 235559 has been marked as a duplicate of this bug. ***

Comment 3 Maros Barabas 2007-04-11 06:57:59 UTC
*** Bug 235911 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.