Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235418 - NetworkManager has problems intermittantly connection to WPA Personal network
Summary: NetworkManager has problems intermittantly connection to WPA Personal network
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 17:07 UTC by Norm Murray
Modified: 2008-10-20 14:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-20 14:59:33 UTC


Attachments (Terms of Use)
The output in var log messages when the applet does not connect (deleted)
2007-04-05 17:08 UTC, Wade Mealing
no flags Details
Output of var log messages when network manager does connect (deleted)
2007-04-05 17:10 UTC, Wade Mealing
no flags Details
And.. it still happens (deleted)
2007-10-25 16:23 UTC, Wade Mealing
no flags Details

Description Wade Mealing 2007-04-05 17:07:19 UTC
Description of problem:

Networkmanager starts, wireless card comes up, selecting a network from the list
(Or when network manager auto-detects my home network, then autoconnects),
NetworkManager will fail to continue the connection.

Version-Release number of selected component (if applicable):

NetworkManager-glib-0.6.5-0.6.svn2474.fc7
NetworkManager-0.6.5-0.6.svn2474.fc7
NetworkManager-gnome-0.6.5-0.6.svn2474.fc7

How reproducible:

1/3 times, but usually when I'm already frustrated after a long days work.

Steps to Reproduce:
1. Boot laptop, log into gnome.
2. See nm-applet do spinny thing
3. tail the var log messages, notice it didnt get a dhcp lease, frown.
  
Actual results:

nm-applet does not connect to my wireless 

Expected results:

nm to connect to my wireless server so I can go about my life.

Additional info:

It seems whenever it fails, I see the log in the messages..

Apr  6 02:43:36  localhost NetworkManager: <info>  Old device 'ath0' activating,
won't change. 

However when it works, I get

Apr  6 02:45:54  localhost kernel: ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready

var log messages sections to be attached.

Comment 1 Wade Mealing 2007-04-05 17:08:07 UTC
Created attachment 151783 [details]
The output in var log messages when the applet does not connect

Comment 2 Wade Mealing 2007-04-05 17:10:28 UTC
Created attachment 151785 [details]
Output of var log messages when network manager does connect

Comment 4 Doncho Gunchev 2007-05-03 19:53:49 UTC
This happens for me about 1/20 times, but gets better, mostly when the signal is
weaker. Does it help if you stop NM; rmmod (your_wls_card_module_here); insmod
(your...) and then restart NM? That works for me...

btw: I used only wpa_supplicant (edit the conf file and start) the first time I
got connected to my AP and it never failed. Maybe NM is not waiting enough at
some point and should certainly not clear my passphrase every time - ask yes,
but fill in the old one. I use the knetworkmanager applet and wpa2 if that matters.

Comment 5 Wade Mealing 2007-06-12 15:10:44 UTC
It usually does, but i cant get it to work properly.

This seems to work though.

#!/bin/bash

service NetworkManger stop
/usr/sbin/wpa_supplicant -dd -Dmadwifi -c/etc/wpa_supplicant/wpa_supplicant.conf
-iath0
/sbin/dhclient ath0


wpa_supplicant is of course populated with the correct values.

Comment 6 Wade Mealing 2007-10-25 15:53:41 UTC
Still happening in F8T3 and current rawhide.



Comment 7 Wade Mealing 2007-10-25 16:23:37 UTC
Created attachment 237581 [details]
And.. it still happens

Updated error messages.. this still works if i set it up manually.

Comment 8 Wade Mealing 2007-10-25 16:42:05 UTC
ok,

set /etc/sysconfig/wpa_supplicant up to look like this
INTERFACES="-i wlan0 "
DRIVERS="-D madwifi -dd"


Start the service, have it start on boot.. make this your wpa_supplicant startup
params, now it works.  Till we meet again networkmanager

Comment 9 Tim Lauridsen 2007-10-26 09:12:38 UTC
I have the same problems in current rawhide, NetworkManager can't connect to my
WPA AP at home.
I works if i use

service NetworkManger stop
/usr/sbin/wpa_supplicant -dd -Dmadwifi -c/etc/wpa_supplicant/wpa_supplicant.conf
-iath0 -B
/sbin/dhclient ath0

I will try modifying /etc/sysconfig/wpa_supplicant when i get home.
why wlan0, shouldn't it be ??
INTERFACES="-i ath0 "



Comment 10 Tim Lauridsen 2007-10-31 08:45:08 UTC
Thanks !!!!.

All my problems with NetworkManager & wpa_supplicant is solved in Rawhide.
NetworkManager connects without any problems to my WPA2 access point on my
Thinkpad T60 (Madwifi driver)

The is a problem connecting after suspend/resume, i have to 
modprobe -r ath_pci
modprobe ath_pci

Then it is working again. (I don't think this issue have any thing todo with NM)



Comment 12 Bug Zapper 2008-05-14 02:44:05 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Dan Williams 2008-10-20 14:59:33 UTC
Ok, fixed in current release then.


Note You need to log in before you can comment on or make changes to this bug.