Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235369 - /etc/shadow has wrong permissions
Summary: /etc/shadow has wrong permissions
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 13:58 UTC by Ray Strode [halfline]
Modified: 2013-03-06 03:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-23 23:58:24 UTC


Attachments (Terms of Use)

Description Ray Strode [halfline] 2007-04-05 13:58:45 UTC
To my great surprise, I discovered this morning that my /etc/shadow file was
world readable.  It didn't really matter, because i'm just on a laptop with only
one user, but I don't think I made it that way.  

I did a livecd install of slightly before test3 and have been synching with
rawhide since.

I asked a few people on IRC to check their shadow files and they were all 0400
so its probably a false alarm, and I did screw it up somehow myself.

Anyway, filing just to be on the safe side, in case there were changes recently
that might be responsible for it.

Feel free to CLOSE -> WORKSFORME if appropriate or whatever.

Comment 1 Phil Knirsch 2007-05-23 14:19:34 UTC
This probably only happens for a livecd install. I've tried it with several
normal installations here and haven't been able to reproduce it.

Maybe check with the livecd guys if they do something special for the
installation? Reassigning to LiveCD component at least for now, as thats the
only real difference i see here.

Read ya, Phil

Comment 2 Jeremy Katz 2007-05-23 23:58:24 UTC
I just did a live install of today's rawhide and it came out looking fine.  I
vaguely remember there being a problem like this at one point that we've since
fixed though, so going to close


Note You need to log in before you can comment on or make changes to this bug.