Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235353 - Rpm unsets verify bit for %doc
Summary: Rpm unsets verify bit for %doc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 12:04 UTC by Jonathan Dieter
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 15:18:28 UTC


Attachments (Terms of Use)

Description Jonathan Dieter 2007-04-05 12:04:54 UTC
Description of problem:
rpm unsets the verify bit for any %docs in the rpm.  This is a problem when
creating deltarpms as deltarpm stores the whole file if the verify bit is off,
and is particularly painful when trying to make a deltarpm of something like
samba which contains 13M of documentation.

Version-Release number of selected component (if applicable):
4.4.2


How reproducible:
Always

Steps to Reproduce:
1. Install yum-metadata-parser
2. Run rpm -q --qf "[%{RPMTAG_FILEVERIFYFLAGS} %{FILENAMES}\n]" yum-metadata-parser
  
Actual results:
-1 /usr/lib/python2.4/site-packages/_sqlitecache.so
-1 /usr/lib/python2.4/site-packages/sqlitecachec.py
-1 /usr/lib/python2.4/site-packages/sqlitecachec.pyc
-1 /usr/lib/python2.4/site-packages/sqlitecachec.pyo
0 /usr/share/doc/yum-metadata-parser-1.0.3
0 /usr/share/doc/yum-metadata-parser-1.0.3/AUTHORS
0 /usr/share/doc/yum-metadata-parser-1.0.3/ChangeLog
0 /usr/share/doc/yum-metadata-parser-1.0.3/README

Expected results:
-1 /usr/lib/python2.4/site-packages/_sqlitecache.so
-1 /usr/lib/python2.4/site-packages/sqlitecachec.py
-1 /usr/lib/python2.4/site-packages/sqlitecachec.pyc
-1 /usr/lib/python2.4/site-packages/sqlitecachec.pyo
-1 /usr/share/doc/yum-metadata-parser-1.0.3
-1 /usr/share/doc/yum-metadata-parser-1.0.3/AUTHORS
-1 /usr/share/doc/yum-metadata-parser-1.0.3/ChangeLog
-1 /usr/share/doc/yum-metadata-parser-1.0.3/README

Comment 1 Jeff Johnson 2007-04-07 02:07:31 UTC
Actually rpm never sets the verify bits for %doc files, mainly because the %verify() attribute
does not scope properly across %doc files.

Even if the behavior were fixed in rpm this very moment, there are zillions
of packages with %doc files with no %verifyflags, so you are likely going to
have to change deltarpm's behavior no matter what.

Comment 2 Jeff Johnson 2007-04-11 01:16:04 UTC
Yes, verify flags for %doc were not initialized correctly.

Fixed in rpm cvs, will be in rpm-4.4.9-0.4 when built.

UPSTREAM

Comment 3 Jonathan Dieter 2007-07-07 12:20:12 UTC
Not fixed in rpm in Rawhide.  Jeff, I appreciate the fix in 4.4.9, but,
unfortunately, we've got 4.4.2 in F7 and 4.4.2.1 in Rawhide.  Paul, do you mind
fixing this in 4.4.2.1 as we're pushing to publish deltarpms in F8.

Comment 4 Jonathan Dieter 2007-07-07 12:23:04 UTC
Sorry, my mistake.  It is fixed in 4.4.2.1.  Feel free to ignore the last comment


Note You need to log in before you can comment on or make changes to this bug.