Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235344 - What has become of xmms.pc?
Summary: What has become of xmms.pc?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul F. Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 235801 (view as bug list)
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-05 10:18 UTC by Michał Bentkowski
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-13 22:00:07 UTC


Attachments (Terms of Use)

Description Michał Bentkowski 2007-04-05 10:18:24 UTC
Hi!
I'm an owner of kadu whose subpackage depends on xmms-devel. It uses xmms.pc
to check whether xmms is installed.
And this is my problem: xmms.pc disappeared and it causes kadu build to fail.
Is xmms.pc going to be back in further releases or should I disable this module 
for kadu?

Comment 1 Paul F. Johnson 2007-04-09 12:12:08 UTC
I'll have a look at this at some point today. The version the rawhide build is
from is a cvs snapshot (fixed lots of bugs), so it's probably why the pc file
has gone.


Comment 2 Michael Schwendt 2007-04-12 21:52:28 UTC
xmms-config is patched with xmms-1.2.10-multidevel.patch
and therefore strictly requires pkg-config!

A diff against FE6 xmms reveals this change that is not
covered in the %changelog:

-install -Dpm 644 xmms.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/xmms.pc
+#install -Dpm 644 xmms.pc %{buildroot}%{_libdir}/pkgconfig/xmms.pc


Comment 3 Michael Schwendt 2007-04-12 21:53:58 UTC
*** Bug 235801 has been marked as a duplicate of this bug. ***

Comment 4 Linus Walleij 2007-04-13 05:39:46 UTC
This bug (as Michael noticed) blocks the rebuild of xmms-adplug too...

Comment 5 Gilboa Davara 2007-04-13 16:41:19 UTC
FYI, this bug blocks the review of kdebluetooth. (Needed for F7/KDE)

- Gilboa

Comment 6 Paul F. Johnson 2007-04-13 22:00:07 UTC
okay, fixed in rawhide. closing

Comment 7 Gilboa Davara 2007-04-16 17:26:15 UTC
ACK.
Working just fine.

Thanks,
- Gilboa

Comment 8 Michał Bentkowski 2007-04-16 21:55:56 UTC
(In reply to comment #7)
> Working just fine.


Yeah, kadu built successfully at last :)


Note You need to log in before you can comment on or make changes to this bug.