Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235331 - msymbol_name returns nil for some m17n input methods
Summary: msymbol_name returns nil for some m17n input methods
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: uim
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 234804
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 08:19 UTC by Jens Petersen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-14 10:40:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 11967 None None None Never

Description Jens Petersen 2007-04-05 08:19:35 UTC
+++ This bug was initially created as a clone of Bug #234804 +++

Description of problem:
Under uim, m17n-nil appears and selecting it can cause focused app to crash.

How reproducible:
every time

Steps to Reproduce:
1. install uim, uim-gtk2, uim-anthy
2. add uim applet to gnome panel or run uim-toolbar-gtk-systray
3. run GTK_IM_MODULE=uim gedit
4. select m17n-nil

Actual results:
4. gedit crashes

Expected results:
4. no m17n-nil in menu

Noticed with m17n installed, m17n-nil appears
in the menu without an icon and that still crashes gedit for me.

-- Additional comment from tagoh@redhat.com on 2007-04-04 23:14 EST --
Hmm, ok. it looks like m17n-lib is weird.
m17nlib module for uim just tries to pick input method up through
mdatabase_list() and register the info from minput_open_im(). AFAICS
minput_open_im returns something other than NULL, but the value able to get
through msymbol_name((MInputMethod *)->name) seems to be nil.

-- Additional comment from tagoh@redhat.com on 2007-04-04 23:27 EST --
Created an attachment (id=151730)
testcase

Here is the actual result what I can get from m17n-lib:

lang: km
name: yannis
lang: ka
name: kbd
lang: el
name: kbd
lang: ko
name: han2
lang: ko
name: romaja
lang: my
name: kbd
lang: dv
name: phonetic
lang: ur
name: phonetic
lang: sk
name: kbd
lang: lo
name: lrt
lang: lo
name: kbd
lang: as
name: inscript
lang: as
name: phonetic
lang: as
name: itrans
lang: te
name: itrans
lang: te
name: inscript
:
:
lang: zh
name: tonepy-gb
lang: zh
name: cangjie
lang: zh
name: bopomofo
lang: zh
name: py-b5
lang: pa
name: phonetic
lang: pa
name: inscript
lang: pa
name: itrans
lang: pa
name: jhelum
lang: t
name: syrc-phonetic
lang: t
name: latn-post
lang: t
name: latn-pre
lang: t
name: rfc1345
lang: t
name: unicode
lang: t
name: nil
lang: t
name: nil
lang: t
name: nil


So the last three seems to be wrong.

Comment 1 ntakahas 2007-04-09 11:23:09 UTC
Auxiliary input methods, e.g. cjk-util.mim, have the name 'nil' since they are
always included by other standalone input methods.  We will update the
documentation to make this point clearer.

Comment 2 Jens Petersen 2007-04-10 00:27:41 UTC
Ok, reassigning to uim on the basis of comment 1.

Comment 3 Akira TAGOH 2007-08-20 02:53:24 UTC
should be fixed in 1.4.1-6.fc8. m17n-nil no longer appears in the list and no
crashes then.


Note You need to log in before you can comment on or make changes to this bug.