Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235323 - 3D rendered contents of window misplaced
Summary: 3D rendered contents of window misplaced
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-via
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-05 03:28 UTC by Gian Paolo Mureddu
Modified: 2018-04-11 15:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-27 21:06:47 UTC


Attachments (Terms of Use)
Screenshot of the glxgears window, showing a slight offset of the render in regards to the window (deleted)
2007-04-05 03:28 UTC, Gian Paolo Mureddu
no flags Details
lspci from Fedora 6 (deleted)
2007-07-11 12:41 UTC, Michael Forrest
no flags Details
xorg.conf file, which has been hand customised (deleted)
2007-07-14 00:59 UTC, Michael Forrest
no flags Details
Xorg.0.log file with my hand customised xorg.conf file (deleted)
2007-07-14 02:13 UTC, Michael Forrest
no flags Details
Xorg.0.log file with no xorg.conf file (deleted)
2007-07-14 02:15 UTC, Michael Forrest
no flags Details
Fedora 7 lspci -vv output (deleted)
2007-07-14 02:25 UTC, Michael Forrest
no flags Details
glxgears in initial position - 3D window is misplaced (deleted)
2007-07-14 02:27 UTC, Michael Forrest
no flags Details
glxgears window frame moved down - 3D window misplaced ecen more! (deleted)
2007-07-14 02:30 UTC, Michael Forrest
no flags Details

Description Gian Paolo Mureddu 2007-04-05 03:28:48 UTC
Description of problem:
When rendering 3D objects with an S3 Unichrome based graphics adapter, using the
via driver, the rendered window is slightly misplaced (see attached screenshot)

Version-Release number of selected component (if applicable):
xorg-x11-drv-via-0.2.2-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Boot up F7T3 LiveCD and log in to the fedora session
2. Open a terminal window
3. Run 'glxgears'. The rendered window will resemble something like the attached
screenshot.
  
Actual results:
Even though the window is rendered, the render is slightly misplaced vertically.

Expected results:
The rendered contents of the window to be correctly placed.

Comment 1 Gian Paolo Mureddu 2007-04-05 03:28:49 UTC
Created attachment 151731 [details]
Screenshot of the glxgears window, showing a slight offset of the render in regards to the window

Comment 2 Gian Paolo Mureddu 2007-04-05 03:30:20 UTC
For completeness sake, here's the lspci output of the VGA adapter in question
(lspci -vv)

01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA
Adapter (rev 01) (prog-if 00 [VGA])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 7142
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (500ns min)
        Interrupt: pin A routed to IRQ 20
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=64M]
        Region 1: Memory at f4000000 (32-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at f5000000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [70] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=7 SBA+ ITACoh- GART64- HTrans-
64bit- FW- AGP3+ Rate=x4,x8
                Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x8

Comment 3 Matthew Miller 2007-04-10 16:35:15 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 4 Gian Paolo Mureddu 2007-04-10 18:34:56 UTC
Yes, it is not obvious as Bugzilla has not reflected the changes in Fedora 7
(like the merger of Core and Extras and some bugs filed for components such as
AbiWord have to be directed to Extras [why is this so beats me]), all the same,
this report was targetted for Fedora 7 devel, and thanks for the clarification.

Comment 5 Michael Forrest 2007-07-11 12:35:17 UTC
There appears to be a regression for me also for 3D rendering on Fedora 7's
via driver.

The glxgears window is missplaced, and if the window is moved from the top
left corner (defauly placement from metacity), the misplacement increases
so that if the window is moved down 100 picels, the 2D window of glxgears
moves down ~200 pixels. Same for howizontal.

This makes 3D totally unuable for me. I will attach lspci -vv output.

Comment 6 Michael Forrest 2007-07-11 12:41:51 UTC
Created attachment 158943 [details]
lspci from Fedora 6

Note that 3D works fine with FC6 using this hardware (I dual boot to either 
6 or 7).

Comment 7 Matěj Cepl 2007-07-11 14:01:04 UTC
Both to reporter and Michael:

Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 8 Michael Forrest 2007-07-14 00:59:47 UTC
Created attachment 159256 [details]
xorg.conf file, which has been hand customised

Comment 9 Michael Forrest 2007-07-14 02:13:44 UTC
Created attachment 159258 [details]
Xorg.0.log file with my hand customised  xorg.conf file

Comment 10 Michael Forrest 2007-07-14 02:15:49 UTC
Created attachment 159259 [details]
Xorg.0.log file with no xorg.conf file

Comment 11 Michael Forrest 2007-07-14 02:23:04 UTC
I have attached the requested information.

I will also attch the lspci from Fedora 7, and two screen shots illustrraing:

- glxgears in its initial position
- glxgears after moving the window framee about 100 pixels down,
  showing that the misplacement has increased compared to the previous
  position

Comment 12 Michael Forrest 2007-07-14 02:25:35 UTC
Created attachment 159260 [details]
Fedora 7 lspci -vv output

Comment 13 Michael Forrest 2007-07-14 02:27:41 UTC
Created attachment 159261 [details]
glxgears in initial position - 3D window is misplaced

Comment 14 Michael Forrest 2007-07-14 02:30:36 UTC
Created attachment 159262 [details]
glxgears window frame moved down - 3D window misplaced ecen more!

Comment 15 Michael Forrest 2007-07-14 05:54:29 UTC
Did a 'yum update' today.

Now, the misplacement problem has disappeared for me.

Can you confirm. glx-maintainers, whether or not the bugfix in:

glx-utils.i386 6.5.2-13.fc7

Could have corrected the problem we have documented here?

I will not move this bug to fixed, since I am not the original reporter.

Comment 16 Adam Jackson 2007-07-27 21:06:47 UTC
Pretty sure this was fixed by Mesa update.  Reopen if I'm wrong.


Note You need to log in before you can comment on or make changes to this bug.