Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235310 - smart-gui fails to load
Summary: smart-gui fails to load
Keywords:
Status: CLOSED DUPLICATE of bug 231735
Alias: None
Product: Fedora
Classification: Fedora
Component: smart
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 23:30 UTC by Stephanos Manos
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-25 21:37:03 UTC


Attachments (Terms of Use)

Description Stephanos Manos 2007-04-04 23:30:53 UTC
Description of problem:
when starting synaptic a popup window appears with "unknown error" 

Version-Release number of selected component (if applicable):
smart-0.50-45.fc7
smart-update-0.50-45.fc7
smart-gui-0.50-45.fc7


How reproducible:
always (when selinux is enabled)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The problem is with the pam file (/etc/pam.d/smart).
changing it to 
auth            include         config-util
account         include         config-util
session         include         config-util

instead of
auth       sufficient   /lib/security/pam_rootok.so
auth       sufficient   /lib/security/pam_timestamp.so
auth       required     /lib/security/pam_stack.so service=system-auth
session    required     /lib/security/pam_permit.so
session    optional     /lib/security/pam_xauth.so
session    optional     /lib/security/pam_timestamp.so
account    required     /lib/security/pam_permit.so

solves the problem

Comment 1 Stephanos Manos 2007-04-18 06:56:07 UTC
ping

Comment 2 Axel Thimm 2007-04-22 12:15:39 UTC
Can you provide some more details? Why does the above fail under selinux and why
does outsourcing into another config file help?

Also the issue description is a copy and paste from your synaptic bug report.
Perhaps the error is this time different than "unknown error"?

Comment 3 Stephanos Manos 2007-04-22 22:06:08 UTC
(In reply to comment #2)
> Also the issue description is a copy and paste from your synaptic bug report.
> Perhaps the error is this time different than "unknown error"?
Exactly the same


Comment 4 Bill Nottingham 2007-05-25 21:37:03 UTC

*** This bug has been marked as a duplicate of 231735 ***


Note You need to log in before you can comment on or make changes to this bug.