Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235309 - synaptic fails to load
Summary: synaptic fails to load
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: synaptic
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 23:25 UTC by Stephanos Manos
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 0.57.2-10.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-08 15:57:08 UTC


Attachments (Terms of Use)

Description Stephanos Manos 2007-04-04 23:25:06 UTC
Description of problem:
when starting synaptic a popup window appears with "unknown error" 

Version-Release number of selected component (if applicable):
synaptic-0.57.2-5.2.fc7

How reproducible:
always (when selinux is enabled)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The problem is with the pam file (/etc/pam.d/synaptic).
changing it to 
auth            include         config-util
account         include         config-util
session         include         config-util

instead of
auth       sufficient   /lib/security/pam_rootok.so
auth       sufficient   /lib/security/pam_timestamp.so
auth       required     /lib/security/pam_stack.so service=system-auth
session    required     /lib/security/pam_permit.so
session    optional     /lib/security/pam_xauth.so
session    optional     /lib/security/pam_timestamp.so
account    required     /lib/security/pam_permit.so

solves the problem

Comment 1 Stephanos Manos 2007-04-18 06:56:44 UTC
ping


Comment 2 Axel Thimm 2007-04-22 12:15:36 UTC
Can you provide some more details? Why does the above fail under selinux and why
does outsourcing into another config file help?


Comment 3 Stephanos Manos 2007-04-22 22:06:05 UTC
(In reply to comment #2)
> Can you provide some more details? Why does the above fail under selinux and why
> does outsourcing into another config file help?
It's not a selinux issue just an observation.
If i open a terminal window and su and then issue synaptic then it works.
So that lead me to think that it's a pam issue.

synaptic and smart are not ne only ones that have this issue. qtparted has it
also BZ #237075



Comment 5 Jonathan Smith 2007-06-02 19:32:35 UTC
Since Test 3 of Fedora 7 up to and including the new release, apt-get fails. So,
of course, synaptic will fail also.

#yum install apt

Installing:
 apt                     i386       0.5.15lorg3.2-9.fc7  fedora            979 k
Installing for dependencies:
 fedora-package-config-apt  noarch     6.89-6           fedora            4.3 k

Installed: apt.i386 0:0.5.15lorg3.2-9.fc7
Dependency Installed: fedora-package-config-apt.noarch 0:6.89-6
Complete!

#apt-get update
Get:1 http://download.fedora.redhat.com fedora/linux/core/7/i386/os/ repomd.xml
[3666B]
0% [1 repomd.xml 0/3666B
0%]/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:6:
parser error : Opening and ending tag mismatch: title line 6 and html
<title>Fedora :: File Not Found :: fedoraproject.org</html>
                                                           ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:95:
parser error : Opening and ending tag mismatch: META line 5 and head
</head>
       ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:135:
parser error : Entity 'copy' not defined
<p>Copyright &copy; 2003, 2004, 2005, 2006, 2007 Red Hat, Inc. and others. All r
                   ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:138:
parser error : Opening and ending tag mismatch: p line 135 and div
</div>
      ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:143:
parser error : Opening and ending tag mismatch: div line 101 and body
</body>
       ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:144:
parser error : Opening and ending tag mismatch: body line 96 and html
</html>
       ^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:145:
parser error : Premature end of data in tag head line 4

^
/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml:145:
parser error : Premature end of data in tag html line 3

^
E: could not open Release file
'/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_7_i386_os_repodata_repomd.xml'
W: Release files for some repositories could not be retrieved or authenticated.
Such repositories are being ignored.
W: Release file did not contain checksum information for
http://download.fedora.redhat.com/pub/fedora/linux/core/7/i386/os/repodata/primary.xml
W: Release file did not contain checksum information for
http://download.fedora.redhat.com/pub/fedora/linux/core/7/i386/os/repodata/filelists.xml
W: Release file did not contain checksum information for
http://download.fedora.redhat.com/pub/fedora/linux/extras/7/i386/repodata/primary.xml
W: Release file did not contain checksum information for
http://download.fedora.redhat.com/pub/fedora/linux/extras/7/i386/repodata/filelists.xml
W: Release file did not contain checksum information for
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/7/i386/repodata/primary.xml
W: Release file did not contain checksum information for
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/7/i386/repodata/filelists.xml
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object
E: Tried to dequeue a fetching object




Comment 6 Fedora Update System 2007-06-04 04:12:24 UTC
synaptic-0.57.2-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Axel Thimm 2007-06-04 09:50:36 UTC
Stephane, can you please test the package in updates-testing? Thanks!

Jonathan, I think what you see is a bug in fedora-package-config-apt, which also
has an update in updates-testing, can you check it out, too?

Comment 8 Stephanos Manos 2007-06-04 16:14:12 UTC
Fixed.

Thanks.

Comment 9 Fedora Update System 2007-06-05 00:10:27 UTC
synaptic-0.57.2-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Jonathan Smith 2007-06-05 02:41:18 UTC
I did a rpm -i --nodeps of fedora-config-apt, then installed apt, which seems to
work again. Unable to install synaptic

rpm -ivh synaptic-0.57.2-6.fc7.i386.rpm

error: Failed dependencies:
        libapt-pkg-libc6.5-6.so.2 is needed by synaptic-0.57.2-6.fc7.i386


Comment 11 Axel Thimm 2007-06-05 07:44:49 UTC
Johnathan, you're using apt from updates-testing, correct? Then you also need to
use synaptics from updates-testing (the one from comment #6).

Comment 12 Jonathan Smith 2007-06-05 11:36:06 UTC
I did try installing synaptic from the same place that I got the working apt.

Comment 13 Axel Thimm 2007-06-06 22:04:33 UTC
> error: Failed dependencies:
>         libapt-pkg-libc6.5-6.so.2 is needed by synaptic-0.57.2-6.fc7.i386

Jonathan, there was a problem in building synaptic against apt in
updates-testing (it's due to the current updates policy, may change soon), but
now the synaptic package in updates-testing should be in sync with the apt
package there, as well.

Just for checking: It will be synaptic-0.57.2-10.fc7 once your mirror carries
it. Can you please verify that this works for you? Thanks!

Comment 14 Jonathan Smith 2007-06-07 12:14:03 UTC
Synaptic installed and wrks4melolz. First time in long time, m soooo  happy
Got best package manager back.

Comment 15 Fedora Update System 2007-06-08 15:57:02 UTC
synaptic-0.57.2-10.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.