Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235306 - system-config-selinux fails to start
Summary: system-config-selinux fails to start
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 23:14 UTC by Stephanos Manos
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-18 11:52:55 UTC


Attachments (Terms of Use)

Description Stephanos Manos 2007-04-04 23:14:28 UTC
Description of problem:
when starting system-config-selinux i get the following
/usr/share/system-config-selinux/system-config-selinux.py:69: Warning:
IA__g_object_get_valist: object class `GnomeProgram' has no property named
`default-icon'
  xml = gtk.glade.XML
("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 168, in
<module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 87, in
__init__
    self.add_page(modulesPage.modulesPage(xml)) # modules
  File "/usr/share/system-config-selinux/modulesPage.py", line 68, in __init__
    self.load()
  File "/usr/share/system-config-selinux/modulesPage.py", line 88, in load
    module, ver = i.split('\t')
ValueError: need more than 1 value to unpack


Version-Release number of selected component (if applicable):
policycoreutils-gui-2.0.7-9.fc7

How reproducible:
always

Steps to Reproduce:
1. from a terminal start system-config-selinux
2.
3.
  
Actual results:
the error message

Expected results:
the program to load

Additional info:

Comment 1 Daniel Walsh 2007-04-05 13:30:23 UTC
What does semodule -i list?

Comment 2 Daniel Walsh 2007-04-05 14:10:08 UTC
Actually semodule -l

Comment 3 Stephanos Manos 2007-04-05 14:37:58 UTC
[root@ghost ~]# semodule -l
No modules.
[root@ghost ~]# 


Comment 4 Stephanos Manos 2007-04-05 20:47:23 UTC
The problem was with seedit. Removimg it the problem was fixed (?)

Comment 5 Will Woods 2007-04-09 01:06:00 UTC
Confirmed here. The following patch is a possible workaround: 

--- /usr/share/system-config-selinux/modulesPage.py.orig        2007-04-08
20:57:23.000000000 -0400
+++ /usr/share/system-config-selinux/modulesPage.py     2007-04-08
20:54:13.000000000 -0400
@@ -85,6 +85,8 @@
         l = fd.readlines()
         fd.close()
         for i in l:
+            if '\t' not in i: 
+                continue
             module, ver = i.split('\t')
             iter = self.store.append()
             self.store.set_value(iter, 0, module.strip())

And, obviously, removing seedit works too.

Comment 6 Daniel Walsh 2007-04-09 14:16:25 UTC
Fixed in policycoreutils-2_0_7-10

Comment 7 Stephanos Manos 2007-04-18 07:00:22 UTC
Yes. It works now.


Note You need to log in before you can comment on or make changes to this bug.