Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235287 - IDE drive had badblocks [5] install menu didnt have option to find
Summary: IDE drive had badblocks [5] install menu didnt have option to find
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 20:28 UTC by stefan fiala
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 15:34:13 UTC


Attachments (Terms of Use)

Description stefan fiala 2007-04-04 20:28:43 UTC
Description of problem:
Had 5 bad blocks on my ide drive. [e2fsck -ck, badblocks -c ...]
It would have been nice if the disk-install-menu had a "readonly scan for
badblocks" checkbox or similar, causing it to auto-add them to the badblock 
file. I used mke2fs -c, e2fsck, and then told the installer to leave the
partitions alone [no format].

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
On one install, prior it installed only to refuse to boot [errors] afterward.
[I presume due to the badblocks being somewhere important].

Expected results:
Further enhancement could be to read-check writes during install...
[No idea how Unices do this, VMS uses a writecheck IO modifier].


Additional info:

Comment 1 Jeremy Katz 2007-04-09 15:34:13 UTC
In general, current drives actually do remapping underneath the level of the OS
and so a badblocks check doesn't actually add anything useful.


Note You need to log in before you can comment on or make changes to this bug.