Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235277 - mkinitrd needs to pull in MODULE_FIRMWARE firmware
Summary: mkinitrd needs to pull in MODULE_FIRMWARE firmware
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact: James Laska
URL:
Whiteboard:
: 380641 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 19:38 UTC by Jon Masters
Modified: 2013-09-02 06:20 UTC (History)
5 users (show)

Fixed In Version: RHBA-2008-0437
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 15:26:14 UTC


Attachments (Terms of Use)
Fix for uninitialized flag in nash's hotplug.c (deleted)
2008-01-18 19:49 UTC, Mike Snitzer
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0437 normal SHIPPED_LIVE mkinitrd bug fix and enhancement update 2008-05-20 13:11:44 UTC

Description Jon Masters 2007-04-04 19:38:03 UTC
We need the MODULE_FIRMWARE enablers already added to Fedora mkinitrd to be in
5.1 too so firmware updating can work.

Jon.

Comment 1 RHEL Product and Program Management 2007-10-16 04:02:46 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Mike Snitzer 2007-12-11 19:20:46 UTC
Any pointers to a mkinitrd package that allows RHEL5U1 firmware
loading/updating?  Stock RHEL5U1 doesn't support it.

Comment 3 Jon Masters 2007-12-11 20:56:51 UTC
I believe this is in RHEL5.1. In order for this to work, your module needs to
make use of the MODULE_FIRMWARE macro, which it might not yet. What's the module?

Jon.

Comment 4 Mike Snitzer 2007-12-12 01:13:11 UTC
The qla2xxx driver from 2.6.19.7.

The following MODULE_FIRMWARE instances exist:
./qla_os.c:MODULE_FIRMWARE(FW_FILE_ISP21XX);
./qla_os.c:MODULE_FIRMWARE(FW_FILE_ISP22XX);
./qla_os.c:MODULE_FIRMWARE(FW_FILE_ISP2300);
./qla_os.c:MODULE_FIRMWARE(FW_FILE_ISP2322);
./qla_os.c:MODULE_FIRMWARE(FW_FILE_ISP24XX);

And "modinfo -F firmware qla2xxx" shows:
ql2400_fw.bin
ql2322_fw.bin
ql2300_fw.bin
ql2200_fw.bin
ql2100_fw.bin

I can also see mkinitrd copying the firmware to the initrd:
`/lib/firmware/ql2300_fw.bin' -> `/tmp/initrd.we3894/lib/firmware/ql2300_fw.bin'

But yet when I load that initrd it still doesn't load/find the firmware.  And
the qla2xxx driver ultimately fails to load.

Could this be at all related to bug#378651 ?

Comment 5 Mike Snitzer 2008-01-18 19:49:54 UTC
Created attachment 292189 [details]
Fix for uninitialized flag in nash's hotplug.c

To respond to my comment#4, FC8's bug#378651 is the issue here.  RHEL5U1 also
does NOT properly load firmware for the qla2xxx.

The attached patch fixes it for RHEL5U1 (as verified with a 2.6.22.16 kernel).

I really need RHEL5U2 to include this mkinitrd fix...

Comment 7 Peter Jones 2008-01-31 23:15:45 UTC
Fixed in mkinitrd-5.1.19.6-21 .

Comment 12 errata-xmlrpc 2008-05-21 15:26:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0437.html


Comment 13 Brian Lane 2012-05-15 18:13:14 UTC
*** Bug 380641 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.