Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235267 - for core files, file doesn't display the executable name
Summary: for core files, file doesn't display the executable name
Keywords:
Status: CLOSED DUPLICATE of bug 172015
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
: 240183 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 19:04 UTC by James Ralston
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-20 14:02:40 UTC


Attachments (Terms of Use)

Description James Ralston 2007-04-04 19:04:44 UTC
I'm not sure when the behavior changed, but recent versions of file (including
the one in Fedora Core 6, Rawhide, and the Fedora 7 test releases) no longer
display the name of the executable that generated a core file when examining the
core file.

FC7test2 / Rawhide:

$ rpm -q file; file core.5676
file-4.20-1.fc7
core.5676: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style

FC6:

$ rpm -q file; file core.5676
file-4.19-1.fc6
core.5676: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style

This isn't caused by a change in the structure of core files, as older versions
of file can identify the executable of core files with no problem:

RHEL4:

[transfer core.5676 from the FC7test2 system]
$ rpm -q file; file core.5676 
file-4.10-2.EL4.4
core.5676: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style,
from 'dig'

This might be a recurrence of bug 172015.

Comment 1 Martin Bacovsky 2007-07-04 10:01:39 UTC
*** Bug 240183 has been marked as a duplicate of this bug. ***

Comment 2 Martin Bacovsky 2007-07-04 10:06:23 UTC
This feature seems to be back in version 4.21. If you still are able to
reproduce this behaviour with updated file feel free to reopen this bz.

Comment 3 James Ralston 2007-07-05 16:08:02 UTC
I see no difference in the behavior with version 4.21, for either i386 or x86_64:

$ uname -m; file --version; file core.5254
x86_64
file-4.21
magic file from /usr/share/file/magic
core.5254: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style

$ uname -m; file --version; file core.5901
i686
file-4.21
magic file from /usr/share/file/magic
core.5901: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style


Comment 4 Per Winkvist 2007-07-08 19:40:07 UTC
I've rebuilt file from rawhide and I still don't get file to show program name 
from a core file:
------------
[perra@localhost ~]$ uname -m; rpm -q file; file --version; file core.*
i686
file-4.21-2.fc7
file-4.21
magic file from /usr/share/file/magic
core.2636: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style
core.3689: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style
core.5896: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style
core.7284: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style


Comment 5 Martin Bacovsky 2007-08-20 14:02:40 UTC

*** This bug has been marked as a duplicate of 172015 ***


Note You need to log in before you can comment on or make changes to this bug.