Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235239 - Anaconda is crashing
Summary: Anaconda is crashing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
: 235378 235438 235609 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-04 17:28 UTC by mail@romal.de
Modified: 2007-11-30 22:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 17:58:39 UTC


Attachments (Terms of Use)

Description mail@romal.de 2007-04-04 17:28:57 UTC
Description of problem:

Anaconda is crashing after todays rawhide update

I'm installing todays radhide from a local mirror using pxe-boot.

Version-Release number of selected component (if applicable):

anaconda-11.2.0.44-1

How reproducible:

Every time.

Steps to Reproduce:
1. try to install todays rawhide
2.
3.
  
Actual results:

anaconda installer init version 11.2.0.44 starting
mount ... filesystems done
.
.
.
running installer
running /sbin/loader
trying method 1 using /sys/bus/pci ok
decided to use linux-sysfs
loader recieved SIGSEGV! Backtrace
0x8048284
0x19b420
0x816c807
.
.
.

install exited anormaly 1/1
sending termination signals
sending kill signals
unmount filesystems ...
you may safely reboot your system



Expected results:


Additional info:

Comment 1 G.Wolfe Woodbury 2007-04-04 22:35:44 UTC
Seen one the work1.private testbed machine too.
Tried various options as "noapic noipv6" and text mode to see if it was simple.
It's a hard crash in the loader on the images/boot.iso


Comment 2 Chris Lumens 2007-04-05 14:55:30 UTC
*** Bug 235378 has been marked as a duplicate of this bug. ***

Comment 3 G.Wolfe Woodbury 2007-04-08 17:05:00 UTC
Still happening with anaconda-11.2.0.45-1
I understand the main repo's are closed for the merger, but this is a major bug.

Comment 4 Bruno Wolff III 2007-04-09 13:03:55 UTC
I am seeing this too. I bult an install DVD from yesterday's (April 8th)
development images and rpms and got the same result as the reporter. This has
been happening less than a week, since I was able to do an install using images
from about April 2nd.

My traceback addresses were:

8048284
e73420
816ca17
816884c
8166a85
8058360
804a732
8171e38
8048131

lspci output:
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller (rev 11)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP
Bridge00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ISA (rev 05)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-768 [Opus] IDE (rev 04)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ACPI (rev 03)
00:07.5 Multimedia audio controller: Advanced Micro Devices [AMD] AMD-768 [Opus]
Audio (rev 03)
00:08.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN
interface00:09.0 RAID bus controller: Triones Technologies, Inc. HPT302 (rev 01)
00:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] PCI (rev 05)
01:05.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
01:05.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary)
(rev 01)
02:00.0 USB Controller: Advanced Micro Devices [AMD] AMD-768 [Opus] USB (rev
07)02:05.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 37)
02:05.1 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 37)
02:06.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
02:07.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0d)
02:08.0 RAID bus controller: Promise Technology, Inc. PDC20276 (MBFastTrak133
Lite) (rev 01)


Comment 5 Chris Lumens 2007-04-09 14:47:57 UTC
*** Bug 235609 has been marked as a duplicate of this bug. ***

Comment 6 Chris Lumens 2007-04-09 14:49:58 UTC
*** Bug 235438 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2007-04-09 17:58:39 UTC
Rebuild of the stack seems to have fixed this

Comment 8 Bruno Wolff III 2007-04-14 14:32:20 UTC
I retested this and it works OK for me now.


Note You need to log in before you can comment on or make changes to this bug.