Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235233 - NetworkManager thinks the wired network is plugged in
Summary: NetworkManager thinks the wired network is plugged in
Keywords:
Status: CLOSED DUPLICATE of bug 230256
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 17:06 UTC by Bastien Nocera
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-21 21:58:09 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2007-04-04 17:06:56 UTC
NetworkManager-0.6.5-0.6.svn2474.fc7
kernel-2.6.20-1.3040.fc7

eth0 is an e100 card

Despite having no wired cable plugged into my machine, NetworkManager still
tried to get an IP address on the wired network.

$ sudo ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: g
        Current message level: 0x00000007 (7)
        Link detected: no

$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:01:4A:00:45:9D  
          inet addr:169.254.197.197  Bcast:169.254.255.255  Mask:255.255.0.0
          inet6 addr: fe80::201:4aff:fe00:459d/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

$ nm-tool
<snip>
- Device: eth0 ----------------------------------------------------------------
  NM Path:           /org/freedesktop/NetworkManager/Devices/eth0
  Type:              Wired
  Driver:            e100
  Active:            no
  HW Address:        00:01:4A:00:45:9D

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Settings
    Hardware Link:   no

Comment 1 Davide Bolcioni 2007-04-27 17:21:27 UTC
Same here with the Fedora 7 test 4 KDE Live CD and ethtool correctly reporting 
no link detected because the cable is unplugged on purpose.

NetworkManager-0.6.5-1.fc7

In /var/log/messages I have:

... NetworkManager: <info> Deactivating device eth0.
... NetworkManager: <info> Will activate wired connection 'eth0' because it 
now has a link.

but it doesn't.

Comment 2 Osma Ahvenlampi 2007-05-21 21:21:33 UTC
looks like dup of #230256

Comment 3 Bastien Nocera 2007-05-21 21:58:09 UTC
A dupe indeed.

*** This bug has been marked as a duplicate of 230256 ***


Note You need to log in before you can comment on or make changes to this bug.