Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235219 - single node mirror leg failure causes > 3 min lvm deadlock
Summary: single node mirror leg failure causes > 3 min lvm deadlock
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2
Version: 5.2
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: LVM and device-mapper development team
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On: 199724
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 16:05 UTC by Scott Crenshaw
Modified: 2010-02-24 21:40 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-24 21:40:27 UTC


Attachments (Terms of Use)

Comment 2 RHEL Product and Program Management 2008-03-11 19:45:25 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 5 Jonathan Earl Brassow 2010-02-09 17:32:18 UTC
Corey, would you be willing to take a look and see if this is still a problem?  I'm pretty sure we block writes when there is a failure (recent rhel5 and upstream kernels), this could speed up the failure processing...

Comment 6 Corey Marthaler 2010-02-09 21:17:08 UTC
I'll look into this. I'm pretty sure that this issue is long gone though (at least in my configurations).

Comment 7 Corey Marthaler 2010-02-24 21:40:27 UTC
I was unable to reproduce this issue while running helter_skelter in single machine mode. Closing, feel free to reopen if ever seen again.


Note You need to log in before you can comment on or make changes to this bug.