Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235201 - Crash in pango when rendering thai email in thunderbird
Summary: Crash in pango when rendering thai email in thunderbird
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pango
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 14:10 UTC by Anthony Green
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-30 18:19:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 409369 None None None Never

Description Anthony Green 2007-04-04 14:10:09 UTC
Description of problem:
thunderbird is crashing in pango whenever it tries to display an email using
thai.  It looks like somebody has also reported this in the gnome bugzilla db.

#0  pango_fc_font_real_get_glyph (font=0x8da8850, wc=3610) at pangofc-font.c:565
565           if (index > (FT_UInt)face->num_glyphs)
(gdb) p face
$7 = (FT_Face) 0x0
(gdb) where 13
#0  pango_fc_font_real_get_glyph (font=0x8da8850, wc=3610) at pangofc-font.c:565
#1  0x00979554 in pango_fc_font_get_glyph (font=0x0, wc=3610) at pangofc-font.c:672
#2  0x00a64e7b in thai_make_glyph_uni (font_info=0x91d1af8, uc=3610) at
thai-fc.c:230
#3  0x00a64ec1 in thai_make_glyph_tis (font_info=0x91d1af8, c=186 '�') at
thai-fc.c:215
#4  0x00a64137 in get_adjusted_glyphs_list (font_info=0x91d1af8,
cluster=0xbfb4f18c, num_chrs=1, glyph_lists=0xbfb4ed8c, 
    shaping_table=0xa65d40) at thai-shaper.c:179
#5  0x00a646ef in get_glyphs_list (font_info=0x91d1af8, cluster=0xbfb4f18c,
num_chrs=1, glyph_lists=0xbfb4ed8c)
    at thai-shaper.c:433
#6  0x00a64c10 in thai_engine_shape (engine=0x8924190, font=0x8da8850, 


Version-Release number of selected component (if applicable):
pango-1.14.10-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.I'm not sure how to extract this email from thuderbird to send to you because
the mailer crashes every time I bring it up.  Maybe simple examination of the
code will make the problem obvious.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michel 2007-05-14 15:55:29 UTC
I am having some what seem to be related problems with any gtk & pango browser.
I'm receiving the following from GDB:

#0  0x0000003cad006fda in pango_fc_font_lock_face () from
/usr/lib64/libpangoft2-1.0.so.0
#1  0x00002aaaba2b8041 in script_engine_init () from
/usr/lib64/pango/1.5.0/modules/pango-thai-fc.so
#2  0x00002aaaba2b7592 in __cxa_pure_virtual () from
/usr/lib64/pango/1.5.0/modules/pango-thai-fc.so
#3  0x00002aaaba2b7e1f in __cxa_pure_virtual () from
/usr/lib64/pango/1.5.0/modules/pango-thai-fc.so
#4  0x0000003cada24b1e in pango_shape () from /usr/lib64/libpango-1.0.so.0
#5  0x0000003cada197dc in pango_layout_set_width () from
/usr/lib64/libpango-1.0.so.0
#6  0x0000003cada1beee in pango_layout_iter_get_char_extents () from
/usr/lib64/libpango-1.0.so.0
#7  0x0000003cada1c40c in pango_layout_iter_get_char_extents () from
/usr/lib64/libpango-1.0.so.0
#8  0x0000003cada1e33e in pango_layout_get_line_count () from
/usr/lib64/libpango-1.0.so.0

If indeed the problem is the same, then a patch is already availablefor pango
(see http://bugzilla.gnome.org/show_bug.cgi?id=411867) which I found as a result
of (http://www.mail-archive.com/desktop-bugs@lists.ubuntu.com/msg67654.html)

To reproduce, attempt browsing to wikipedia and attempt a search for "search
engines". 100% crash rate for me.

Comment 2 Behdad Esfahbod 2007-05-15 07:12:58 UTC
I checked the code.  Nothing obviously wrong.

Can you attach the mail?  To make thunderbird not crash, move the file
/usr/lib/pango/1.5.0/modules/pango-thai-fc.so out of the way temporarily.

Thanks,


Re comment #1, no, this is a separate problem than the upstream bug you link to.

Comment 3 Liang Zhang 2007-09-28 08:58:14 UTC
The upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=481212


Comment 4 Liang Zhang 2007-09-29 03:00:49 UTC
The same bug in the upstream bugzilla was closed.


Note You need to log in before you can comment on or make changes to this bug.