Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235192 - GFS2: kernel bug after mount
Summary: GFS2: kernel bug after mount
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Whitehouse
QA Contact: GFS Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 12:50 UTC by Walter Extra
Modified: 2010-01-12 03:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-06 10:10:30 UTC


Attachments (Terms of Use)

Description Walter Extra 2007-04-04 12:50:38 UTC
Description of problem: Right after mounting a local gfs2 partition a kernel bug
is reported.


Version-Release number of selected component (if applicable):
GFS2 from CVS

How reproducible:
mount -t gfs2 -p lock_nolock ...

Steps to Reproduce:
1. Install Debian
2. Install kernel 2.6.21-rc5
3. Install GFS2 from CVS
4. Create GFS2 filesystem on local disk and try to mount
  
Actual results:
kernel BUG reported
------------[ cut here ]------------
Kernel BUG at dea7d0e8 [verbose debug info unavailable]
invalid opcode: 0000 [#1]
Modules linked in: lock_nolock lock_dlm dlm configfs gfs2 ipv6 analog gameport
floppy pcspkr i2c_sis96x i2c_core shpchp pci_hotplug sis_agp agpgart r8169
sis900 mii fuse dm_mod psmouse ide_cd cdrom genrtc ext3 jbd ide_disk ide_generic
via82cxxx trm290 triflex slc90e66 sis5513 siimage serverworks sc1200 rz1000 piix
pdc202xx_old opti621 ns87415 hpt366 hpt34x generic cy82c693 cs5530 cs5520 cmd64x
atiixp amd74xx alim15x3 aec62xx pdc202xx_new ide_core unix
CPU:    0
EIP:    0060:[<dea7d0e8>]    Not tainted VLI
EFLAGS: 00010246   (2.6.21-rc5 #1)
EIP is at gfs2_glmutex_unlock+0x18/0x1c [gfs2]
eax: dea7eb99   ebx: d4b00ab4   ecx: dabc2000   edx: d4b00a84
esi: d4b00a40   edi: d4b5ffac   ebp: fffffffc   esp: d4b5ff68
ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Process gfs2_glockd (pid: 2781, ti=d4b5e000 task=d8d40570 task.ti=d4b5e000)
Stack: dea7e1c6 dabc2000 d4b5ff8c dea764c7 00000000 d8d40570 c01248d9 d4b5ffa4 
       d4b5ffa4 c0112f39 00000000 00000001 00000000 d8d40570 c01248d9 d4b5ffa4 
       d4b5ffa4 0000009b c1439070 d8d03dbc d8d03dbc dabc2000 dea764aa c0124630 
Call Trace:
 [<dea7e1c6>] gfs2_reclaim_glock+0x66/0x72 [gfs2]
 [<dea764c7>] gfs2_glockd+0x1d/0xca [gfs2]
 [<c01248d9>] autoremove_wake_function+0x0/0x33
 [<c0112f39>] __wake_up_common+0x35/0x56
 [<c01248d9>] autoremove_wake_function+0x0/0x33
 [<dea764aa>] gfs2_glockd+0x0/0xca [gfs2]
 [<c0124630>] kthread+0x72/0x97
 [<c01245be>] kthread+0x0/0x97
 [<c010464f>] kernel_thread_helper+0x7/0x10
 =======================
Code: 0f 64 a1 08 00 00 00 89 42 24 8b 04 24 89 42 28 89 c8 c3 0f ba 70 08 01 c7
40 28 00 00 00 00 c7 40 24 00 00 00 00 e8 7e fe ff ff <0f> 0b eb fe 56 31 c9 53
89 c3 56 89 d6 8b 53 3c 8b 02 0f 18 00 
EIP: [<dea7d0e8>] gfs2_glmutex_unlock+0x18/0x1c [gfs2] SS:ESP 0068:d4b5ff68
------------[ cut here ]------------
Kernel BUG at dea7d0e8 [verbose debug info unavailable]
invalid opcode: 0000 [#2]
Modules linked in: lock_nolock lock_dlm dlm configfs gfs2 ipv6 analog gameport
floppy pcspkr i2c_sis96x i2c_core shpchp pci_hotplug sis_agp agpgart r8169
sis900 mii fuse dm_mod psmouse ide_cd cdrom genrtc ext3 jbd ide_disk ide_generic
via82cxxx trm290 triflex slc90e66 sis5513 siimage serverworks sc1200 rz1000 piix
pdc202xx_old opti621 ns87415 hpt366 hpt34x generic cy82c693 cs5530 cs5520 cmd64x
atiixp amd74xx alim15x3 aec62xx pdc202xx_new ide_core unix
CPU:    0
EIP:    0060:[<dea7d0e8>]    Not tainted VLI
EFLAGS: 00010246   (2.6.21-rc5 #1)
EIP is at gfs2_glmutex_unlock+0x18/0x1c [gfs2]
eax: d4b00c14   ebx: d4b00c14   ecx: 00000001   edx: d4b00c58
esi: d4b00c14   edi: 00000001   ebp: dabc2000   esp: d04fbf98
ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Process gfs2_scand (pid: 2780, ti=d04fa000 task=d04f95b0 task.ti=d04fa000)
Stack: dea7e210 dea7e22b 00000b41 dabc2000 dea76480 fffffffc dea7e28f dabc2000 
       dabc2000 dea7648c d8d03dbc c0124630 00000001 ffffffff ffffffff c01245be 
       00000000 00000000 00000000 c010464f d8d03db4 00000000 00000000 00000000 
Call Trace:
 [<dea7e210>] examine_bucket+0x3e/0x59 [gfs2]
 [<dea7e22b>] scan_glock+0x0/0x4f [gfs2]
 [<dea76480>] gfs2_scand+0x0/0x2a [gfs2]
 [<dea7e28f>] gfs2_scand_internal+0x15/0x20 [gfs2]
 [<dea7648c>] gfs2_scand+0xc/0x2a [gfs2]
 [<c0124630>] kthread+0x72/0x97
 [<c01245be>] kthread+0x0/0x97
 [<c010464f>] kernel_thread_helper+0x7/0x10
 =======================
Code: 0f 64 a1 08 00 00 00 89 42 24 8b 04 24 89 42 28 89 c8 c3 0f ba 70 08 01 c7
40 28 00 00 00 00 c7 40 24 00 00 00 00 e8 7e fe ff ff <0f> 0b eb fe 56 31 c9 53
89 c3 56 89 d6 8b 53 3c 8b 02 0f 18 00 
EIP: [<dea7d0e8>] gfs2_glmutex_unlock+0x18/0x1c [gfs2] SS:ESP 0068:d04fbf98

Comment 1 Kiersten (Kerri) Anderson 2007-04-23 17:43:31 UTC
Fixing Product Name.  Cluster Suite components were integrated into Enterprise
Linux for verion 5.0.

Comment 2 Steve Whitehouse 2008-03-05 21:17:19 UTC
This appears to have fallen through the cracks. Its a Debian kernel, but its
reported against RHEL. Its a kernel bug, but its reported against the userland
packages.

I suspect its no longer a problem as this was a long time ago. I missed it since
it didn't have GFS2 in the title of the bug, which I've now added.

Can we close this one now, or is this still a problem? If it needs to be left
open then since its "upstream" as far as I'm concerned, I'll change it to
rawhide/gfs2-kernel.

Comment 3 Walter Extra 2008-03-06 08:00:48 UTC
You can close this bug.

Comment 4 Steve Whitehouse 2008-03-06 10:10:30 UTC
We don't really have a good "resolution" to cover this eventuality, so I'm using
WONTFIX as the nearest thing which the system will let me do.

If you need to open bugs in the future for "other" kernels (i.e. not RHEL) then
please do so against Fedora/rawhide and also mark them against gfs-kernel if
they are kernel related otherwise I might not see them. Putting GFS2 in the
title of the bug is another good thing to do since then it comes up on my bug list.



Note You need to log in before you can comment on or make changes to this bug.