Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235178 - resource agents probe more often than configured
Summary: resource agents probe more often than configured
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
: 243740 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 10:58 UTC by Bryn M. Reeves
Modified: 2009-04-16 22:37 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0580
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 16:45:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix fix (deleted)
2007-04-04 19:16 UTC, Lon Hohberger
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0580 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2007-10-30 15:37:24 UTC

Description Bryn M. Reeves 2007-04-04 10:58:02 UTC
Description of problem:
The metadata in the fs.sh resource agent suggests that the default poll interval
is 2m:

        <!-- Checks to see if it's mounted in the right place -->
        <action name="status" interval="2m" timeout="10"/>
        <action name="monitor" interval="2m" timeout="10"/>

        <!-- Note: active monitoring is constant and supplants all
             check depths -->
        <!-- Checks to see if we can read from the mountpoint -->
        <action name="status" depth="10" timeout="30" interval="2m"/>
        <action name="monitor" depth="10" timeout="30" interval="2m"/>

        <!-- Checks to see if we can write to the mountpoint (if !ROFS) -->
        <action name="status" depth="20" timeout="30" interval="2m"/>
        <action name="monitor" depth="20" timeout="30" interval="2m"/>

When debug is enabled, syslog seems to show the script polling around every 1m:

Mar 12 09:20:26 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:21:27 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:22:27 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:22:37 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:23:29 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:24:28 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:24:39 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:25:29 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)


Version-Release number of selected component (if applicable):
1.9.63-1 (hotfix)

How reproducible:
100%

Steps to Reproduce:
1. Configure a filesystem resource that uses the fs.sh agent in cluster.conf
2. Enable debug logging
3. Start cluster services and enable the service using the file system resource
configured in 1.
  
Actual results:
Probe interval as logged to syslog appears to be 1m.

Expected results:
Probe interval matches configuration information in fs.sh

Comment 1 Lon Hohberger 2007-04-04 19:16:28 UTC
Created attachment 151701 [details]
Fix fix

Comment 2 Lon Hohberger 2007-04-09 15:41:35 UTC
Fix isn't quite correct after testing further - it breaks 'rg_test'.

Comment 3 RHEL Product and Program Management 2007-06-15 20:14:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Lon Hohberger 2007-06-18 20:46:55 UTC
This should have been fixed in CVS for some time.

Comment 6 Marek Grac 2007-06-19 19:19:39 UTC
*** Bug 243740 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2007-11-07 16:45:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0580.html



Note You need to log in before you can comment on or make changes to this bug.