Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235176 - Up2date tomcat5 UnboundLocalError
Summary: Up2date tomcat5 UnboundLocalError
Keywords:
Status: CLOSED DUPLICATE of bug 235748
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.4
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Bret McMillan
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 10:42 UTC by Eva Schaller
Modified: 2014-07-25 03:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-22 15:04:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eva Schaller 2007-04-04 10:42:18 UTC
Description of problem:
When installing Tomcat5 using up2date a python exception is triggered.

Version-Release number of selected component (if applicable):
up2date-4.5.5-1.e14
rhnlib-1.8.7-4

How reproducible:
up2date tomcat5

Steps to Reproduce:
1. up2date java-1.5.0-bea-devel
2. up2date postgresql-server postgresql-jdbc
3. up2date tomcat5
  
Actual results:
Return an exception error saying: 
UnboundLocalError

From /var/log/up2date : 
[Wed Apr  4 09:25:35 2007] up2date solving dep for: ['xml-commons']
[Wed Apr  4 09:25:36 2007] up2date   File "/usr/sbin/up2date", line
1288, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 806, in main
    fullUpdate, dryRun=options.dry_run))
   File "/usr/sbin/up2date", line 1143, in batchRun
    batch.run()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 78, in run
    self.__dryRun()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 163, in
__dryRun
    self.percentCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 380, in dryRun
    ret = depsolve.solvedep()
   File "/usr/share/rhn/up2date_client/depSolver.py", line 752, in
solvedep
    ret = self.process_deps(deps)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 646, in
process_deps
    changed = self.__dependencies(dependencies)
File "/usr/share/rhn/up2date_client/depSolver.py", line 409, in
__dependencies
    if iPkg[4] == aPkg[4] or iPkg[4] == "noarch" or aPkg[4] == "noarch":

Then I try to install 
up2date xml-commons-apis

And it return the same UnboundLocalError; checking in /var/log/up2date I saw: 
[Wed Apr  4 09:53:05 2007] up2date Package xml-commons-apis raised a
dep, but it is obsoleted by:
[['xml-commons-jaxp-1.3-apis', '1.3.03', '5jpp_1rh', '0', 'noarch',
'xml-commons-apis', '0:1.3.02-2jpp', '10']]
[Wed Apr  4 09:53:05 2007] up2date   File "/usr/sbin/up2date", line
1272, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 791, in main
    fullUpdate, dryRun=options.dry_run))
   File "/usr/sbin/up2date", line 1127, in batchRun
    batch.run()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 82, in run
    self.__dryRun()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 204, in
__dryRun
    self.percentCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 384, in dryRun
    ret = depsolve.solvedep()
   File "/usr/share/rhn/up2date_client/depSolver.py", line 752, in
solvedep
ret = self.process_deps(deps)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 646, in
process_deps
    changed = self.__dependencies(dependencies)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 409, in
__dependencies
    if iPkg[4] == aPkg[4] or iPkg[4] == "noarch" or aPkg[4] == "noarch":

So I installed xml-commons-jaxp and this allow me to install Tomcat5.

Expected results:
Tomcat5 installs without any error.

Additional info:

Comment 1 Red Hat Bugzilla 2007-04-12 02:19:44 UTC
User bnackash@redhat.com's account has been closed

Comment 2 Todd Sanders 2007-05-22 15:04:03 UTC

*** This bug has been marked as a duplicate of 235748 ***


Note You need to log in before you can comment on or make changes to this bug.