Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235156 - On-chip RMX mode cause video corrupt on IBM server
Summary: On-chip RMX mode cause video corrupt on IBM server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Airlie
QA Contact:
URL:
Whiteboard:
: 235157 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-04 03:39 UTC by LisaWu
Modified: 2009-06-19 16:31 UTC (History)
12 users (show)

Fixed In Version: RHEA-2008-0474
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 17:31:00 UTC


Attachments (Terms of Use)
while validate DFP modes, we matching modes from EDID info by default (deleted)
2007-04-04 03:39 UTC, LisaWu
no flags Details | Diff
radeon-change-DFP-mode-validation-routine.patch (deleted)
2007-04-19 17:35 UTC, IBM Bug Proxy
no flags Details
disable on-chip RMX using ddc_mode option (deleted)
2007-04-20 02:59 UTC, LisaWu
no flags Details


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 33777 None None None Never
Red Hat Product Errata RHEA-2008:0474 normal SHIPPED_LIVE xorg-x11-drv-ati enhancement and bug fix update 2008-05-20 14:21:07 UTC

Description LisaWu 2007-04-04 03:39:10 UTC
Description of problem:
when install RHEL5-BETA2 on IBM Lewis server, video on local monitor is in 
poor quality, and there is no video output on remote control.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.3-1.el5.rpm

How reproducible:
always

Steps to Reproduce:
1.connect a monitor to server
2.log in to the remote control 
3.install rhel5-beta2 and start X-windows
  
Expected results:
following modes on both local monitor and remote control should be OK.
vesa mode: 1024x768@75hz, 70hz,60hz
           800x600@75hz,72hz,60hz
           
Actual results:
None of the above modes are OK.

Additional info:
on-chip RMX mode is only enabled when the driver thinks it’s driving a digital 
panel which will cause poor quality on CRT. This is also an old day’s radeon 
driver preference that probably shouldn’t be used any more because almost all 
modern TMDS panels have internal scaler which usually can result in better 
quality than our internal RMX.
in our case, radeon driver use RMX modes for remote video by default, however, 
the stretched RMX modes can't be well support. 
To fix this bug, we can change digital pannel mode validation routine not to 
use RMX mode by default, but validate modes by matching modes from EDID info 
instead.

Comment 1 LisaWu 2007-04-04 03:39:11 UTC
Created attachment 151641 [details]
while validate DFP modes, we matching modes from EDID info by default

Comment 2 LisaWu 2007-04-04 03:48:14 UTC
#235157 is the duplicate of this one. sorry for the inconvenience.


Comment 3 IBM Bug Proxy 2007-04-19 17:35:30 UTC
Created attachment 153036 [details]
radeon-change-DFP-mode-validation-routine.patch

Comment 4 IBM Bug Proxy 2007-04-19 17:36:09 UTC
----- Additional Comments From gilliam@us.ibm.com  2007-04-19 13:33 EDT -------
 
Patch from RedHat

Reverse mirror of an attachment 

Comment 5 LisaWu 2007-04-20 02:17:02 UTC
more information is available at upstream bugzilla:
https://bugs.freedesktop.org/show_bug.cgi?id=10620

Comment 6 LisaWu 2007-04-20 02:59:12 UTC
Created attachment 153082 [details]
disable on-chip RMX using ddc_mode option

we would like to disable on-chip RMX by enable ddc_mode option. with this
modification, there will be minimal impact to the upstream Xorg.
when IBM Lewis server is detected, ddc_mode is automatically enabled, so the
on-chip RMX will be disabled for this machine.

Comment 7 Rod Macdonald 2007-07-10 21:58:36 UTC
Can you advise if this latest patch is acceptable for the next RH update?  And 
if so has it been scheduled?

Comment 8 Matěj Cepl 2007-08-17 13:14:48 UTC
*** Bug 235157 has been marked as a duplicate of this bug. ***

Comment 9 Adam Jackson 2007-10-04 16:05:15 UTC
Looks fine to me.  Devel ack, target for 5.2.

Comment 10 RHEL Product and Program Management 2007-10-16 04:02:50 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 12 IBM Bug Proxy 2007-12-06 16:57:01 UTC
------- Comment From ajackson@redhat.com 2007-10-04 12:05 EST-------

Comment 14 John Poelstra 2008-04-23 17:38:50 UTC
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot6--available now on partners.redhat.com.  

We are nearing GA for 5.2 so please test and confirm that your issue is fixed ASAP.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you


Comment 16 errata-xmlrpc 2008-05-21 17:31:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0474.html



Note You need to log in before you can comment on or make changes to this bug.